summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-09 07:03:07 +0000
committerSam James <sam@gentoo.org>2022-02-09 07:03:07 +0000
commit6760b37ba3cd6ced52bfa4ec3538c8b20b3468a6 (patch)
tree769c4f82e9850e648bd5e4a501dc8d54866456d1 /dev-libs/pugixml
parentdev-libs/double-conversion: sparc stable wrt bug #832620 (diff)
downloadgentoo-6760b37ba3cd6ced52bfa4ec3538c8b20b3468a6.tar.gz
gentoo-6760b37ba3cd6ced52bfa4ec3538c8b20b3468a6.tar.bz2
gentoo-6760b37ba3cd6ced52bfa4ec3538c8b20b3468a6.zip
dev-libs/pugixml: add 1.12
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/pugixml')
-rw-r--r--dev-libs/pugixml/Manifest1
-rw-r--r--dev-libs/pugixml/pugixml-1.12.ebuild20
-rw-r--r--dev-libs/pugixml/pugixml-9999.ebuild8
3 files changed, 25 insertions, 4 deletions
diff --git a/dev-libs/pugixml/Manifest b/dev-libs/pugixml/Manifest
index e5df8ab6a1fa..9c4fb41221cf 100644
--- a/dev-libs/pugixml/Manifest
+++ b/dev-libs/pugixml/Manifest
@@ -1 +1,2 @@
DIST pugixml-1.11.4.tar.gz 386229 BLAKE2B 93d9c537f10e3a12297e4d6a39f2866bd5c9678c6aff83e20fb79b6587191b6586b1fe4d9dd995a7be05cc9281cd9910fae3eddf6b2eac216873e918a5cf3231 SHA512 c83f57ef2492eee359d979597fb5089b8eca547bb9d41cfbb6bcf43d59fe75e6780b0f31dd593145ec9888c065153aba52702667e2de213fa080cd51e9e13a38
+DIST pugixml-1.12.tar.gz 389685 BLAKE2B 190ebd1e7ac298a4ef6bc35769151f4d606a88185d29cfad7acb813990e3c9b2bf5b17c461f321942a3af0688c2244a896eb0129df8def5aff63b1d65aa3f6dc SHA512 1d23fc8b0aa643b932d34012be6d545734f5177d7db711fe1f0b82e318d72b5850a8c3d8513393b86b5a1e83ee7bfd825877f9efbf801369adfcb88041b52a93
diff --git a/dev-libs/pugixml/pugixml-1.12.ebuild b/dev-libs/pugixml/pugixml-1.12.ebuild
new file mode 100644
index 000000000000..dd62094ec7ee
--- /dev/null
+++ b/dev-libs/pugixml/pugixml-1.12.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/zeux/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/zeux/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Light-weight, simple, and fast XML parser for C++ with XPath support"
+HOMEPAGE="https://pugixml.org/ https://github.com/zeux/pugixml"
+
+LICENSE="MIT"
+SLOT="0"
diff --git a/dev-libs/pugixml/pugixml-9999.ebuild b/dev-libs/pugixml/pugixml-9999.ebuild
index 13e703458881..dd62094ec7ee 100644
--- a/dev-libs/pugixml/pugixml-9999.ebuild
+++ b/dev-libs/pugixml/pugixml-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake
@@ -10,11 +10,11 @@ if [[ ${PV} == *9999 ]] ; then
inherit git-r3
else
SRC_URI="https://github.com/zeux/${PN}/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
fi
DESCRIPTION="Light-weight, simple, and fast XML parser for C++ with XPath support"
-HOMEPAGE="https://pugixml.org/ https://github.com/zeux/pugixml/"
+HOMEPAGE="https://pugixml.org/ https://github.com/zeux/pugixml"
LICENSE="MIT"
SLOT="0"