summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-02-02 21:12:54 -0800
committerMatt Turner <mattst88@gentoo.org>2022-02-02 22:20:42 -0800
commit8ca38bb0d6ba8da73cb5ae834d485853d3c28c4c (patch)
tree2a404fe295e7ee86dea2de678360c93a99c96bdc /dev-libs/wayland-protocols
parentnet-misc/iperf: add 3.11 (diff)
downloadgentoo-8ca38bb0d6ba8da73cb5ae834d485853d3c28c4c.tar.gz
gentoo-8ca38bb0d6ba8da73cb5ae834d485853d3c28c4c.tar.bz2
gentoo-8ca38bb0d6ba8da73cb5ae834d485853d3c28c4c.zip
dev-libs/wayland-protocols: Version bump to 1.25
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/wayland-protocols')
-rw-r--r--dev-libs/wayland-protocols/Manifest1
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.25.ebuild38
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-9999.ebuild2
3 files changed, 40 insertions, 1 deletions
diff --git a/dev-libs/wayland-protocols/Manifest b/dev-libs/wayland-protocols/Manifest
index 0c9cb95b812b..509c83e1acca 100644
--- a/dev-libs/wayland-protocols/Manifest
+++ b/dev-libs/wayland-protocols/Manifest
@@ -1,2 +1,3 @@
DIST wayland-protocols-1.23.tar.xz 74116 BLAKE2B a92f9d80e8d9062fb79c06e13141b46e0f43d0813f461e087a9fa724fa752df3b4fe5698e34e7431f3b43cca0adf7b86ab77c948060f6c02e4c7693f7975cd15 SHA512 11f09147da1dd01a9f5c921eb0bfc6244a72023a052ef96bc121e16437a2c43d0dbba748c2de832539f57371e90b16bd13069bec07391305717f8fca295ea2a6
DIST wayland-protocols-1.24.tar.xz 77120 BLAKE2B 912132cb2b65b99184f25942e02000444ce5d37b60f33363999e8431db5835d3c0dab41dae312f0dbb02d03ab7e4f3f588e7b507e767ec132a82fd816700b09a SHA512 4b1122517db56f48a5fafd4bd0cb7f94faef6fdd2d80e6cec17e5a6bafbaf2f5a71b958ed12e6d13965494885c209b2fb6dd8331487b39c6f251e71f1e770a15
+DIST wayland-protocols-1.25.tar.xz 79784 BLAKE2B 6ca7fdc910bfd70ee5c3bb192bcf1c79c66c4bb713531b2d1d493bd3ec8509e1231176144d75f4e97a4c6ccc4ee1d836a7ac1cfeaaa59e927f10fa4a40cf023a SHA512 8269694a0780e4d32f1982ff4cbb50b1ef85f08157b9486bc6d7e489c64665a9d9f959121d0eede7c7b108a604d974b64d74cfdef8b5f14304465309afb0768f
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.25.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.25.ebuild
new file mode 100644
index 000000000000..0cd7ff00a4f7
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.25.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/${PN}.git/"
+ inherit git-r3
+else
+ SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? ( dev-libs/wayland )
+"
+RDEPEND=""
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}
diff --git a/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild b/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild
index f9b1910a51a1..0cd7ff00a4f7 100644
--- a/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild
+++ b/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7