summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-10 11:21:09 +0000
committerSam James <sam@gentoo.org>2024-01-10 11:21:57 +0000
commit231fb829f816206e368c83c44e3f3a175b217918 (patch)
tree1fefe76c5402680f7b006b70e62153d6cb65de8e /dev-libs/xerces-c/xerces-c-9999.ebuild
parentsci-mathematics/form: remove old version (diff)
downloadgentoo-231fb829f816206e368c83c44e3f3a175b217918.tar.gz
gentoo-231fb829f816206e368c83c44e3f3a175b217918.tar.bz2
gentoo-231fb829f816206e368c83c44e3f3a175b217918.zip
dev-libs/xerces-c: disable strict aliasing, filter LTO
It's only in the tests but it implies they're not testing it at all. Closes: https://bugs.gentoo.org/856100 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/xerces-c/xerces-c-9999.ebuild')
-rw-r--r--dev-libs/xerces-c/xerces-c-9999.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/dev-libs/xerces-c/xerces-c-9999.ebuild b/dev-libs/xerces-c/xerces-c-9999.ebuild
index 4b24ee3df5d8..fea427072055 100644
--- a/dev-libs/xerces-c/xerces-c-9999.ebuild
+++ b/dev-libs/xerces-c/xerces-c-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake prefix
+inherit cmake flag-o-matic prefix
-DESCRIPTION="A validating XML parser written in a portable subset of C++"
+DESCRIPTION="Validating XML parser written in a portable subset of C++"
HOMEPAGE="https://xerces.apache.org/xerces-c/"
if [[ ${PV} == *9999 ]] ; then
@@ -33,7 +33,10 @@ BDEPEND="
DOCS=( CREDITS KEYS NOTICE README )
-PATCHES=( "${FILESDIR}"/${PN}-3.2.2-fix-XERCESC-2163.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.2.2-fix-XERCESC-2163.patch
+ "${FILESDIR}"/${PN}-3.2.4-strict-aliasing.patch
+)
pkg_setup() {
export ICUROOT="${EPREFIX}/usr"
@@ -45,6 +48,10 @@ pkg_setup() {
}
src_configure() {
+ # bug #856100
+ filter-lto
+ append-flags -fno-strict-aliasing
+
# 'cfurl' is only available on OSX and 'socket' isn't supposed to work.
# But the docs aren't clear about it, so we would need some testing...
local netaccessor