summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-30 19:20:37 +0000
committerSam James <sam@gentoo.org>2022-06-30 19:32:44 +0000
commite875040ac623c2937f6d2a6592e57494ba0d07ad (patch)
treedb547b991d6b94d263af6e3aab9a71403b703f55 /dev-libs
parentdev-libs/openssl: add 1.1.1p (diff)
downloadgentoo-e875040ac623c2937f6d2a6592e57494ba0d07ad.tar.gz
gentoo-e875040ac623c2937f6d2a6592e57494ba0d07ad.tar.bz2
gentoo-e875040ac623c2937f6d2a6592e57494ba0d07ad.zip
dev-libs/openssl: backport test fix for 1.1.1p
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/openssl/files/openssl-1.1.1p-fix-test-build.patch46
-rw-r--r--dev-libs/openssl/openssl-1.1.1p.ebuild3
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-libs/openssl/files/openssl-1.1.1p-fix-test-build.patch b/dev-libs/openssl/files/openssl-1.1.1p-fix-test-build.patch
new file mode 100644
index 000000000000..f96e54f3127e
--- /dev/null
+++ b/dev-libs/openssl/files/openssl-1.1.1p-fix-test-build.patch
@@ -0,0 +1,46 @@
+https://github.com/openssl/openssl/issues/18619
+https://github.com/openssl/openssl/pull/18634
+https://github.com/openssl/openssl/commit/665ab12ed3f0d78e7cb6a55cdd2b83a2fe150232
+
+From 665ab12ed3f0d78e7cb6a55cdd2b83a2fe150232 Mon Sep 17 00:00:00 2001
+From: Bernd Edlinger <bernd.edlinger@hotmail.de>
+Date: Fri, 17 Jun 2022 10:25:24 +0200
+Subject: [PATCH] Fix compile issues in test/v3ext.c with no-rfc3779
+
+There are no ASIdentifiers if OPENSSL_NO_RFC3779 is defined,
+therefore the test cannot be compiled.
+
+Reviewed-by: Matt Caswell <matt@openssl.org>
+Reviewed-by: Tomas Mraz <tomas@openssl.org>
+Reviewed-by: Paul Dale <pauli@openssl.org>
+(Merged from https://github.com/openssl/openssl/pull/18634)
+
+(cherry picked from commit b76efe61ea9710a8f69e1cb8caf1aeb2ba6f1ebe)
+--- a/test/v3ext.c
++++ b/test/v3ext.c
+@@ -37,6 +37,7 @@ static int test_pathlen(void)
+ return ret;
+ }
+
++#ifndef OPENSSL_NO_RFC3779
+ static int test_asid(void)
+ {
+ ASN1_INTEGER *val1 = NULL, *val2 = NULL;
+@@ -113,6 +114,7 @@ static int test_asid(void)
+ ASIdentifiers_free(asid4);
+ return testresult;
+ }
++#endif /* OPENSSL_NO_RFC3779 */
+
+ OPT_TEST_DECLARE_USAGE("cert.pem\n")
+
+@@ -127,6 +129,8 @@ int setup_tests(void)
+ return 0;
+
+ ADD_TEST(test_pathlen);
++#ifndef OPENSSL_NO_RFC3779
+ ADD_TEST(test_asid);
++#endif /* OPENSSL_NO_RFC3779 */
+ return 1;
+ }
+
diff --git a/dev-libs/openssl/openssl-1.1.1p.ebuild b/dev-libs/openssl/openssl-1.1.1p.ebuild
index 90f1683c106f..f4af78d2c330 100644
--- a/dev-libs/openssl/openssl-1.1.1p.ebuild
+++ b/dev-libs/openssl/openssl-1.1.1p.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/openssl.org.asc
inherit edo flag-o-matic toolchain-funcs multilib-minimal verify-sig
@@ -47,6 +47,7 @@ PATCHES=(
# If they're Gentoo specific, add to USE=-vanilla logic in src_prepare!
"${FILESDIR}"/${PN}-1.1.0j-parallel_install_fix.patch #671602
"${FILESDIR}"/${PN}-1.1.1i-riscv32.patch
+ "${FILESDIR}"/${P}-fix-test-build.patch
)
pkg_setup() {