summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-12-14 18:25:07 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-12-14 18:57:39 +0100
commit1a2855749663d48825bfc3892755a6b14bf92159 (patch)
tree23a90f576bd470d6971de37190912286d97c1691 /dev-lua/LuaBitOp
parentdev-lua/LuaBitOp: add luajit (slotted) (diff)
downloadgentoo-1a2855749663d48825bfc3892755a6b14bf92159.tar.gz
gentoo-1a2855749663d48825bfc3892755a6b14bf92159.tar.bz2
gentoo-1a2855749663d48825bfc3892755a6b14bf92159.zip
dev-lua/LuaBitOp: drop old version
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/LuaBitOp')
-rw-r--r--dev-lua/LuaBitOp/LuaBitOp-1.0.2-r101.ebuild88
1 files changed, 0 insertions, 88 deletions
diff --git a/dev-lua/LuaBitOp/LuaBitOp-1.0.2-r101.ebuild b/dev-lua/LuaBitOp/LuaBitOp-1.0.2-r101.ebuild
deleted file mode 100644
index 66c4e3131492..000000000000
--- a/dev-lua/LuaBitOp/LuaBitOp-1.0.2-r101.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..2} )
-
-inherit lua multilib-minimal toolchain-funcs
-
-DESCRIPTION="Bit Operations Library for the Lua Programming Language"
-HOMEPAGE="http://bitop.luajit.org"
-SRC_URI="http://bitop.luajit.org/download/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="test"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-RESTRICT="!test? ( test )"
-
-RDEPEND="${LUA_DEPS}"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-HTML_DOCS=( "doc/." )
-
-src_prepare() {
- default
-
- lua_copy_sources
- lua_foreach_impl multilib_copy_sources
-}
-
-lua_multilib_src_compile() {
- pushd "${WORKDIR}/${P}-${ELUA/./-}-${MULTILIB_ABI_FLAG}.${ABI}" || die
-
- local myemakeargs=(
- "CC=$(tc-getCC)"
- "CCOPT="
- "INCLUDES=$(lua_get_CFLAGS)"
- )
-
- emake "${myemakeargs[@]}" all
-
- popd
-}
-
-multilib_src_compile() {
- lua_foreach_impl lua_multilib_src_compile
-}
-
-lua_multilib_src_test() {
- pushd "${WORKDIR}/${P}-${ELUA/./-}-${MULTILIB_ABI_FLAG}.${ABI}" || die
-
- local mytests=(
- "bitbench.lua"
- "bittest.lua"
- "md5test.lua"
- "nsievebits.lua"
- )
-
- for mytest in ${mytests[@]}; do
- LUA_CPATH="./?.so" ${ELUA} ${mytest}
- done
-
- popd
-}
-
-multilib_src_test() {
- multilib_is_native_abi && lua_foreach_impl lua_multilib_src_test
-}
-
-lua_multilib_src_install() {
- pushd "${WORKDIR}/${P}-${ELUA/./-}-${MULTILIB_ABI_FLAG}.${ABI}" || die
-
- exeinto $(lua_get_cmod_dir)
- doexe bit.so
-
- popd
-}
-
-multilib_src_install() {
- lua_foreach_impl lua_multilib_src_install
-}
-
-multilib_src_install_all() {
- einstalldocs
-}