summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-06-22 21:43:17 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-06-22 22:00:11 +0200
commit0fae7f43309fb10745cb8c5ab434af38a7d7efc3 (patch)
tree730532630b52ee4980b25fd39ef4b8583a8255f5 /dev-lua
parentdev-lua/lua-term: drop 0.7-r2 (diff)
downloadgentoo-0fae7f43309fb10745cb8c5ab434af38a7d7efc3.tar.gz
gentoo-0fae7f43309fb10745cb8c5ab434af38a7d7efc3.tar.bz2
gentoo-0fae7f43309fb10745cb8c5ab434af38a7d7efc3.zip
dev-lua/mpack: drop 1.0.11
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/mpack/Manifest1
-rw-r--r--dev-lua/mpack/mpack-1.0.11.ebuild116
2 files changed, 0 insertions, 117 deletions
diff --git a/dev-lua/mpack/Manifest b/dev-lua/mpack/Manifest
index 0d98ae862c6e..3dc9c54148b4 100644
--- a/dev-lua/mpack/Manifest
+++ b/dev-lua/mpack/Manifest
@@ -1,2 +1 @@
-DIST mpack-1.0.11.tar.gz 16305 BLAKE2B e076043259692dc1aecbb62498cd44e523a44e40c265adeb3edc088f7b81a9e5892b13bbb730107fe64804be684c15510e8aea603abdafc2003c659e6bff9143 SHA512 2bd76e3d12928cb51f475d58e2c8b749f4b2b8b45f72296f6dd46c13b31fee80e0c4859de9332a7232842f511e4a53d30b43aad563980fd026d04fd65fb57b7e
DIST mpack-1.0.12.tar.gz 16524 BLAKE2B 7b2d5dbdbb72f6d792e366259ef5ba080872417b558ff8d4fd0877f5a9fbeb8794d6e1657034b74f0dffe5e1c03c0339060eebf9e85370619938cc7b8f03c540 SHA512 7df730ba98c9530d948252f2efa70cb6d4f65b0fbc3443de2239145e9ce1aa12dfa8acbbfd4b87edf19a529e3595c7a8955e00235f69aa3535d353f7f9a1c7d0
diff --git a/dev-lua/mpack/mpack-1.0.11.ebuild b/dev-lua/mpack/mpack-1.0.11.ebuild
deleted file mode 100644
index 2cc20b76c877..000000000000
--- a/dev-lua/mpack/mpack-1.0.11.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-
-inherit lua toolchain-funcs
-
-MY_PN="lib${PN}-lua"
-
-DESCRIPTION="Lua bindings for libmpack"
-HOMEPAGE="https://github.com/libmpack/libmpack-lua/"
-SRC_URI="https://github.com/${MY_PN/-lua/}/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc x86 ~x64-macos"
-IUSE="test"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-libs/libmpack
- ${LUA_DEPS}
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
- test? (
- dev-lua/busted[${LUA_USEDEP}]
- dev-lua/lua_cliargs[${LUA_USEDEP}]
- ${RDEPEND}
- )
-"
-
-src_prepare() {
- default
-
- lua_copy_sources
-}
-
-lua_src_compile() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- "CC=$(tc-getCC)"
- "LUA_INCLUDE=$(lua_get_CFLAGS)"
- "LUA_LIB="
- "USE_SYSTEM_MPACK=yes"
- "USE_SYSTEM_LUA=yes"
- )
-
- emake "${myemakeargs[@]}"
-
- popd
-}
-
-src_compile() {
- lua_foreach_impl lua_src_compile
-}
-
-lua_src_test() {
- pushd "${BUILD_DIR}" || die
-
- # "[ FAILED ] test.lua @ 279: mpack should not leak memory"
- # It doesn't seem upstream actually support LuaJIT so were this up to me
- # I would drop it from LUA_COMPAT, unfortunately there are packages in the
- # tree which currently expect it to be supported.
- if [[ ${ELUA} == "luajit" ]]; then
- ewarn "Not running tests under ${ELUA} because they are known to fail"
- return
- fi
-
- busted --lua="${ELUA}" test.lua || die
-
- popd
-}
-
-src_test() {
- lua_foreach_impl lua_src_test
-}
-
-lua_src_install() {
- pushd "${BUILD_DIR}" || die
-
- local installdir="$(lua_get_cmod_dir)"
- local myemakeargs=(
- "DESTDIR=${ED}"
- "LUA_CMOD_INSTALLDIR=${installdir#$EPREFIX}"
- "USE_SYSTEM_MPACK=yes"
- "USE_SYSTEM_LUA=yes"
- )
-
- emake "${myemakeargs[@]}" install
-
- popd
-
- if [[ ${CHOST} == *-darwin* ]] ; then
- local luav=$(lua_get_version)
- # we only want the major version (e.g. 5.1)
- local luamv=${luav:0:3}
- local file="lua/${luamv}/mpack.so"
- install_name_tool \
- -id "${EPREFIX}/usr/$(get_libdir)/${file}" \
- "${ED}/usr/$(get_libdir)/${file}" \
- || die "Failed to adjust install_name"
- fi
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-
- einstalldocs
-}