summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-07-20 01:57:23 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-07-20 02:00:36 +0200
commite0cd8e155e3bdc1b1cf15aef3e632891c9faf412 (patch)
treec2d6b2b48806f6bab35d387cbaf70ac5a33dec30 /dev-lua
parentmedia-libs/libsdl2: Stabilize 2.28.5-r2 arm, #936319 (diff)
downloadgentoo-e0cd8e155e3bdc1b1cf15aef3e632891c9faf412.tar.gz
gentoo-e0cd8e155e3bdc1b1cf15aef3e632891c9faf412.tar.bz2
gentoo-e0cd8e155e3bdc1b1cf15aef3e632891c9faf412.zip
dev-lua/luasystem: add missing build parts
Needed, as otherwise other dev-lua/* packages will fail tests. Closes: https://bugs.gentoo.org/935634 Closes: https://bugs.gentoo.org/935635 Closes: https://bugs.gentoo.org/935636 Closes: https://bugs.gentoo.org/935637 Closes: https://bugs.gentoo.org/935638 Closes: https://bugs.gentoo.org/935639 Closes: https://bugs.gentoo.org/935640 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luasystem/files/luasystem-0.4.2-fix-makefile.patch49
-rw-r--r--dev-lua/luasystem/luasystem-0.4.2-r1.ebuild (renamed from dev-lua/luasystem/luasystem-0.4.2.ebuild)2
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-lua/luasystem/files/luasystem-0.4.2-fix-makefile.patch b/dev-lua/luasystem/files/luasystem-0.4.2-fix-makefile.patch
new file mode 100644
index 000000000000..2d930a29fe78
--- /dev/null
+++ b/dev-lua/luasystem/files/luasystem-0.4.2-fix-makefile.patch
@@ -0,0 +1,49 @@
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -50,7 +50,7 @@
+ # /usr/local/include/lua$(LUA_VERSION)
+ # where lua headers are found for linux builds
+ LUAINC_linux_base?=/usr/include
+-LUAINC_linux?=$(LUAINC_linux_base)/lua/$(LUA_VERSION)
++LUAINC_linux?=$(LUAINC_linux_base)/lua$(LUA_VERSION)
+ LUAPREFIX_linux?=/usr/local
+ CDIR_linux?=lib/lua/$(LUA_VERSION)
+ LDIR_linux?=share/lua/$(LUA_VERSION)
+@@ -144,8 +144,8 @@
+ CC_linux=gcc
+ DEF_linux=
+ CFLAGS_linux= -I$(LUAINC) $(DEF) -Wall -Wshadow -Wextra \
+- -Wimplicit -O2 -ggdb3 -fpic -fvisibility=hidden
+-LDFLAGS_linux=-lrt -O -shared -fpic -o
++ -Wimplicit -fpic -fvisibility=hidden
++LDFLAGS_linux=-lrt -shared -fpic -o
+ LD_linux=gcc
+
+ #------
+@@ -208,7 +208,7 @@
+ #
+ CC=$(CC_$(PLAT))
+ DEF=$(DEF_$(PLAT))
+-CFLAGS=$(MYCFLAGS) $(CFLAGS_$(PLAT))
++CFLAGS=$(CFLAGS_$(PLAT)) $(MYCFLAGS)
+ LDFLAGS=$(MYLDFLAGS) $(LDFLAGS_$(PLAT))
+ LD=$(LD_$(PLAT))
+ LUAINC= $(LUAINC_$(PLAT))
+@@ -217,7 +217,7 @@
+ #------
+ # Objects
+ #
+-OBJS=core.$(O) compat.$(O) time.$(O) environment.$(O) random.$(O) term.$(O)
++OBJS=core.$(O) compat.$(O) time.$(O) environment.$(O) random.$(O) term.$(O) bitflags.$(O) wcwidth.$(O)
+
+ #------
+ # Targets
+@@ -248,7 +248,7 @@
+ all: $(SOLIB)
+
+ $(SOLIB): $(OBJS)
+- $(LD) $(OBJS) $(LDFLAGS)$@
++ $(LD) $(OBJS) $(LDFLAGS) $@
+
+ install: all
+ $(INSTALL_DIR) $(INSTALL_TOP_LDIR)
diff --git a/dev-lua/luasystem/luasystem-0.4.2.ebuild b/dev-lua/luasystem/luasystem-0.4.2-r1.ebuild
index 3bfbf46ba5c8..edc7640b031c 100644
--- a/dev-lua/luasystem/luasystem-0.4.2.ebuild
+++ b/dev-lua/luasystem/luasystem-0.4.2-r1.ebuild
@@ -31,7 +31,7 @@ BDEPEND="
)
"
-PATCHES=( "${FILESDIR}"/${PN}-0.2.1_p0-fix-makefile.patch )
+PATCHES=( "${FILESDIR}"/${PN}-0.4.2-fix-makefile.patch )
src_prepare() {
default