summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2020-10-13 16:03:07 +1100
committerMark Wright <gienah@gentoo.org>2020-10-13 23:53:22 +1100
commit0b42f5e355ba13dce9dada9c547d10a7e5ef2c3b (patch)
tree899bf7e5b8a6619b944ce83ef32b9cdd050c38ad /dev-ml/camlp5
parentdev-ml/camlp4: Bump to 4.11_p1 (diff)
downloadgentoo-0b42f5e355ba13dce9dada9c547d10a7e5ef2c3b.tar.gz
gentoo-0b42f5e355ba13dce9dada9c547d10a7e5ef2c3b.tar.bz2
gentoo-0b42f5e355ba13dce9dada9c547d10a7e5ef2c3b.zip
dev-ml/camlp5: Bump to 7.12
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Mark Wright <gienah@gentoo.org>
Diffstat (limited to 'dev-ml/camlp5')
-rw-r--r--dev-ml/camlp5/Manifest1
-rw-r--r--dev-ml/camlp5/camlp5-7.12.ebuild61
-rw-r--r--dev-ml/camlp5/files/camlp5-7.12-destdir.patch13
-rw-r--r--dev-ml/camlp5/metadata.xml4
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-ml/camlp5/Manifest b/dev-ml/camlp5/Manifest
index 88a996b85b6d..f99200f89122 100644
--- a/dev-ml/camlp5/Manifest
+++ b/dev-ml/camlp5/Manifest
@@ -1 +1,2 @@
DIST camlp5-7.11.tar.gz 878224 BLAKE2B f384764da43653a2f75664681a4f202ec84497720470a0a33f99fc61a1ce7b4a9d494ffe6b523c74906c122ee04ae25a08bf1fcd356145e85a11e3e3095bbf7d SHA512 109a43f0a3aaa7a3ba9bd51b1fc1273b054d32787e189b138d69b39c42642b480c13abb9e91f15e6b6e889eaf4dc422ad3ff51e4dee298fb9d8cd9a2db99c159
+DIST camlp5-7.12.tar.gz 1008350 BLAKE2B 8f390f6d617a6ef029462aa74ca4d80c0e2eb267bb6957aac43fdecc425aae34dfc7f3e572c8a1f4ee6b032dd90b3b8262094f80a19ea0bb19b80a88d22d3f28 SHA512 233d973b0a968a7812b977e8a37da8e8daa0f3ef81ca7c473d83c1602380dae6c14f94daffb6bb799f8d90fab121238a46e89a233202cd6f622b0da2f728c0c0
diff --git a/dev-ml/camlp5/camlp5-7.12.ebuild b/dev-ml/camlp5/camlp5-7.12.ebuild
new file mode 100644
index 000000000000..59d3a95dc7e3
--- /dev/null
+++ b/dev-ml/camlp5/camlp5-7.12.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib vcs-clean
+
+DESCRIPTION="A preprocessor-pretty-printer of ocaml"
+HOMEPAGE="https://camlp5.github.io/"
+SRC_URI="https://github.com/camlp5/camlp5/archive/rel$(ver_rs 1- '').tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-rel$(ver_rs 1- '')"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="doc +ocamlopt"
+
+DEPEND="
+ >=dev-lang/ocaml-3.10:=[ocamlopt?]
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-7.12-destdir.patch" )
+
+camlp5_hack_ocaml_support() {
+ ln -s "${1}" "ocaml_stuff/${2}" || die
+ ln -s "${1}.ml" "ocaml_src/lib/versdep/${2}.ml" || die
+}
+
+src_prepare() {
+ egit_clean
+ default
+ camlp5_hack_ocaml_support 4.11.0 4.11.1
+}
+
+src_configure() {
+ ./configure \
+ --strict \
+ -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/$(get_libdir)/ocaml \
+ -mandir /usr/share/man || die "configure failed"
+}
+
+src_compile(){
+ emake out
+ if use ocamlopt; then
+ emake opt
+ emake opt.opt
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ # findlib support
+ insinto "$(ocamlfind printconf destdir)/${PN}"
+ doins etc/META
+
+ dodoc -r doc/*
+ dodoc CHANGES DEVEL ICHANGES README.md UPGRADING MODE
+}
diff --git a/dev-ml/camlp5/files/camlp5-7.12-destdir.patch b/dev-ml/camlp5/files/camlp5-7.12-destdir.patch
new file mode 100644
index 000000000000..d43a29c97d3f
--- /dev/null
+++ b/dev-ml/camlp5/files/camlp5-7.12-destdir.patch
@@ -0,0 +1,13 @@
+Index: camlp5-rel712/Makefile
+===================================================================
+--- camlp5-rel712.orig/Makefile
++++ camlp5-rel712/Makefile
+@@ -57,7 +57,7 @@ install:
+ for i in $(DIRS) compile; do \
+ (cd $$i; $(MAKE) install DESTDIR=$(DESTDIR); cd ..); \
+ done
+- cp etc/topfind.camlp5 `ocamlc -where`/. || true
++ cp etc/topfind.camlp5 "$(DESTDIR)`ocamlc -where`/." || true
+
+ uninstall:
+ @if test -z "$(LIBDIR)"; then \
diff --git a/dev-ml/camlp5/metadata.xml b/dev-ml/camlp5/metadata.xml
index 7994efd51d47..cafe415ffc77 100644
--- a/dev-ml/camlp5/metadata.xml
+++ b/dev-ml/camlp5/metadata.xml
@@ -5,6 +5,10 @@
<email>tupone@gentoo.org</email>
<name>Tupone Alfredo</name>
</maintainer>
+ <maintainer type="person">
+ <email>gienah@gentoo.org</email>
+ <name>Mark Wright</name>
+ </maintainer>
<upstream>
<remote-id type="github">camlp5/camlp5</remote-id>
</upstream>