summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/cudf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/cudf')
-rw-r--r--dev-ml/cudf/Manifest2
-rw-r--r--dev-ml/cudf/cudf-0.7.ebuild65
-rw-r--r--dev-ml/cudf/cudf-0.8.ebuild65
-rw-r--r--dev-ml/cudf/metadata.xml5
4 files changed, 137 insertions, 0 deletions
diff --git a/dev-ml/cudf/Manifest b/dev-ml/cudf/Manifest
new file mode 100644
index 000000000000..6f115b5440a2
--- /dev/null
+++ b/dev-ml/cudf/Manifest
@@ -0,0 +1,2 @@
+DIST cudf-0.7.tar.gz 54821 SHA256 92c8a9ed730bbac73f3513abab41127d966c9b9202ab2aaffcd02358c030a701 SHA512 6adf17c076c0308416f6f8bccb361d03645909f535e6cd0ba34860706e5f26628d33ab4f208fb8def28de1499649279febafd895bdde498f35a77e06128e64fa WHIRLPOOL 798ca87c1cc48d00e62a1e6d627fe6d35839fb16d6b2b10ba42f3eea29e3a48e2f5b070b93647a53833a471b1a6a665e759ab3b7cc2bda238d2dec4a8eb0866e
+DIST cudf-0.8.tar.gz 55147 SHA256 06f8ce019c87893e27d545b5cf8dc38041657a4c4856c02be4e99e8175874229 SHA512 cea9e51094076089b1beb657f6b2ccc6ac5f49660e06743f8ec646b277beb4c830f90156ae240a6903de55d09caee78fb0dc75efd76ca65fd2b40ab8756301e3 WHIRLPOOL 2834b5a3d15bbbefc51cd5e54c1ee2155481cecbc91838fca94470b06750576c0719504e51e858145bdae657de739809007bb5b5958469d71010492f245651af
diff --git a/dev-ml/cudf/cudf-0.7.ebuild b/dev-ml/cudf/cudf-0.7.ebuild
new file mode 100644
index 000000000000..de13bb168942
--- /dev/null
+++ b/dev-ml/cudf/cudf-0.7.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="Library to parse, pretty print, and evaluate CUDF documents"
+HOMEPAGE="http://www.mancoosi.org/cudf/"
+SRC_URI="https://gforge.inria.fr/frs/download.php/file/33593/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt test"
+
+RDEPEND="
+ >=dev-lang/ocaml-3.12:=[ocamlopt?]
+ dev-ml/extlib:=
+ dev-libs/glib:2
+ || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )
+ dev-ml/findlib
+ dev-lang/perl
+"
+
+src_prepare() {
+ sed -i \
+ -e 's|make|$(MAKE)|g' \
+ Makefile || die
+ sed -i \
+ -e 's|-lncurses|$(shell ${PKG_CONFIG} --libs ncurses glib-2.0)|g' \
+ c-lib/Makefile || die
+ sed -i \
+ -e 's|-lcurses|$(shell ${PKG_CONFIG} --libs ncurses glib-2.0)|g' \
+ c-lib/Makefile.variants || die
+
+ tc-export CC PKG_CONFIG
+
+ sed -i \
+ -e "s|-lncurses|$( $(tc-getPKG_CONFIG) --libs ncurses)|g" \
+ c-lib/cudf.pc.in || die
+}
+
+src_compile() {
+ emake -j1 all
+ emake c-lib
+ if use ocamlopt ; then
+ emake -j1 opt
+ emake c-lib-opt
+ fi
+}
+
+src_test() {
+ emake test
+ emake c-lib-test
+}
+
+src_install() {
+ emake DESTDIR="${ED}" LIBDIR="/usr/$(get_libdir)" install
+ dodoc BUGS ChangeLog README TODO
+}
diff --git a/dev-ml/cudf/cudf-0.8.ebuild b/dev-ml/cudf/cudf-0.8.ebuild
new file mode 100644
index 000000000000..5b36bb3deeaf
--- /dev/null
+++ b/dev-ml/cudf/cudf-0.8.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="Library to parse, pretty print, and evaluate CUDF documents"
+HOMEPAGE="http://www.mancoosi.org/cudf/"
+SRC_URI="https://gforge.inria.fr/frs/download.php/file/34659/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt test"
+
+RDEPEND="
+ >=dev-lang/ocaml-3.12:=[ocamlopt?]
+ dev-ml/extlib:=
+ dev-libs/glib:2
+ || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )
+ dev-ml/findlib
+ dev-lang/perl
+"
+
+src_prepare() {
+ sed -i \
+ -e 's|make|$(MAKE)|g' \
+ Makefile || die
+ sed -i \
+ -e 's|-lncurses|$(shell ${PKG_CONFIG} --libs ncurses glib-2.0)|g' \
+ c-lib/Makefile || die
+ sed -i \
+ -e 's|-lcurses|$(shell ${PKG_CONFIG} --libs ncurses glib-2.0)|g' \
+ c-lib/Makefile.variants || die
+
+ tc-export CC PKG_CONFIG
+
+ sed -i \
+ -e "s|-lncurses|$( $(tc-getPKG_CONFIG) --libs ncurses)|g" \
+ c-lib/cudf.pc.in || die
+}
+
+src_compile() {
+ emake -j1 all
+ emake c-lib
+ if use ocamlopt ; then
+ emake -j1 opt
+ emake c-lib-opt
+ fi
+}
+
+src_test() {
+ emake test
+ emake c-lib-test
+}
+
+src_install() {
+ emake DESTDIR="${ED}" LIBDIR="/usr/$(get_libdir)" install
+ dodoc BUGS ChangeLog README TODO
+}
diff --git a/dev-ml/cudf/metadata.xml b/dev-ml/cudf/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/cudf/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>