summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-04-01 08:58:59 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-04-01 08:59:53 +0200
commitb1ec083929e9b36d4f83cc6c4788b5bdf8d58d44 (patch)
treeff2bdd3117552514305d20b057017d8473e57fdd /dev-ml/findlib
parentwww-apps/jekyll: drop 4.2.2 (diff)
downloadgentoo-b1ec083929e9b36d4f83cc6c4788b5bdf8d58d44.tar.gz
gentoo-b1ec083929e9b36d4f83cc6c4788b5bdf8d58d44.tar.bz2
gentoo-b1ec083929e9b36d4f83cc6c4788b5bdf8d58d44.zip
dev-ml/findlib: avoid building unused things
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/findlib')
-rw-r--r--dev-ml/findlib/findlib-1.9.6-r1.ebuild (renamed from dev-ml/findlib/findlib-1.9.6.ebuild)9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-ml/findlib/findlib-1.9.6.ebuild b/dev-ml/findlib/findlib-1.9.6-r1.ebuild
index 277e992bd77e..a344a50250c8 100644
--- a/dev-ml/findlib/findlib-1.9.6.ebuild
+++ b/dev-ml/findlib/findlib-1.9.6-r1.ebuild
@@ -22,6 +22,13 @@ src_prepare() {
default
export ocamlfind_destdir="${EPREFIX}/usr/$(get_libdir)/ocaml"
export stublibs="${ocamlfind_destdir}/stublibs"
+ sed -i \
+ -e "/dbm/d" \
+ -e "/graphics/d" \
+ -e "/ocamlbuild/d" \
+ -e "/check_library num/d" \
+ configure \
+ || die
}
src_configure() {
@@ -54,7 +61,7 @@ src_install() {
fi
# See bug #803275 and bug #833604
- for x in camlp4 dbm graphics labltk num num-top ocamlbuild; do
+ for x in camlp4 labltk; do
rm -rf "${ED}"/usr/$(get_libdir)/ocaml/${x} || die
done
}