summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-08-02 11:24:01 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-08-02 11:24:01 +0200
commite1b399e69abadc3bb7463a4f910ca5fe35ee2388 (patch)
tree8df02dd447e0c09e5df2af21a8749ddcafc4aa92 /dev-ml/ocaml-mysql/ocaml-mysql-1.2.1.ebuild
parentapp-text/xindy: add dep on dev-texlive/texlive-fontsrecommended; bug #586190 (diff)
downloadgentoo-e1b399e69abadc3bb7463a4f910ca5fe35ee2388.tar.gz
gentoo-e1b399e69abadc3bb7463a4f910ca5fe35ee2388.tar.bz2
gentoo-e1b399e69abadc3bb7463a4f910ca5fe35ee2388.zip
dev-ml/ocaml-mysql: bump to 1.2.1
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ml/ocaml-mysql/ocaml-mysql-1.2.1.ebuild')
-rw-r--r--dev-ml/ocaml-mysql/ocaml-mysql-1.2.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/ocaml-mysql/ocaml-mysql-1.2.1.ebuild b/dev-ml/ocaml-mysql/ocaml-mysql-1.2.1.ebuild
new file mode 100644
index 000000000000..70e513a31dc5
--- /dev/null
+++ b/dev-ml/ocaml-mysql/ocaml-mysql-1.2.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to mysql databases"
+SRC_URI="http://ygrek.org.ua/p/release/ocaml-mysql/${P}.tar.gz"
+HOMEPAGE="http://ocaml-mysql.forge.ocamlcore.org/"
+
+DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ sys-libs/zlib
+ >=virtual/mysql-4.0"
+
+RDEPEND="$DEPEND"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_compile()
+{
+ emake all
+ if use ocamlopt; then
+ emake opt
+ fi
+}
+
+src_install()
+{
+ findlib_src_preinst
+ emake install
+
+ dodoc CHANGES README VERSION || die
+}