summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-06-04 07:10:43 +1200
committerKent Fredric <kentnl@gentoo.org>2017-06-04 07:22:25 +1200
commite6b0c67a6a0565bb6e0e50d74e3a9d0bc88e2842 (patch)
tree0baab8a6c703280e26d2ac4efe512fee01f33748 /dev-perl/Data-FormValidator/Data-FormValidator-4.860.0-r1.ebuild
parentdev-python/urwid: move ~arm64 keyword forward (diff)
downloadgentoo-e6b0c67a6a0565bb6e0e50d74e3a9d0bc88e2842.tar.gz
gentoo-e6b0c67a6a0565bb6e0e50d74e3a9d0bc88e2842.tar.bz2
gentoo-e6b0c67a6a0565bb6e0e50d74e3a9d0bc88e2842.zip
dev-perl/Data-FormValidator: Add fix for '.' in @INC re bug #613378
This avoids the '.' in @INC issue by absolutizing paths at construction time so that "do" never loads any path other than the one the user assumed would be read. Bug: https://bugs.gentoo.org/613378 Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Data-FormValidator/Data-FormValidator-4.860.0-r1.ebuild')
-rw-r--r--dev-perl/Data-FormValidator/Data-FormValidator-4.860.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/Data-FormValidator/Data-FormValidator-4.860.0-r1.ebuild b/dev-perl/Data-FormValidator/Data-FormValidator-4.860.0-r1.ebuild
new file mode 100644
index 000000000000..e91a4c28da9d
--- /dev/null
+++ b/dev-perl/Data-FormValidator/Data-FormValidator-4.860.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DFARRELL
+DIST_VERSION=4.86
+inherit perl-module
+
+DESCRIPTION="Validates user input (usually from an HTML form) based on input profile"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+PATCHES=( "${FILESDIR}/4.86-dot-in-inc.patch" )
+RDEPEND="dev-perl/Image-Size
+ >=dev-perl/Date-Calc-5.0
+ >=dev-perl/File-MMagic-1.17
+ >=dev-perl/MIME-Types-1.005
+ >=dev-perl/Regexp-Common-0.30.0
+ dev-perl/Email-Valid
+ virtual/perl-File-Spec
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+src_test() {
+ perl_rm_files t/pod.t
+ perl-module_src_test
+}