summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-27 21:49:27 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-27 21:49:27 +1200
commitf8991bec6e19fc73ecc833b00dd87b7ea7ff41d5 (patch)
tree3900158bda77c3890db2ba43a673db7fad78006f /dev-perl/DateTime-TimeZone/DateTime-TimeZone-2.390.0.ebuild
parentdev-perl/DateTime-Set: -r bump for EAPI7 + new test dep (diff)
downloadgentoo-f8991bec6e19fc73ecc833b00dd87b7ea7ff41d5.tar.gz
gentoo-f8991bec6e19fc73ecc833b00dd87b7ea7ff41d5.tar.bz2
gentoo-f8991bec6e19fc73ecc833b00dd87b7ea7ff41d5.zip
dev-perl/DateTime-TimeZone: Bump to version 2.390.0
- EAPI7 Upstream: - Update to Olson 2020a - Adds: Africa::{Juba,Sao_Tome} - Adds: America::Nuuk - Adds: Asia::Qostanay - Removes: America::Godthab - Add support for Etc/GMT and Etc/UTC style zones - Handle "inifinity" as an infinite value in serialized objects. - Make local zone lookup code handle /usr/share/zoneinfo being a symlink Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/DateTime-TimeZone/DateTime-TimeZone-2.390.0.ebuild')
-rw-r--r--dev-perl/DateTime-TimeZone/DateTime-TimeZone-2.390.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/DateTime-TimeZone/DateTime-TimeZone-2.390.0.ebuild b/dev-perl/DateTime-TimeZone/DateTime-TimeZone-2.390.0.ebuild
new file mode 100644
index 000000000000..f714ff1ce95b
--- /dev/null
+++ b/dev-perl/DateTime-TimeZone/DateTime-TimeZone-2.390.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=2.39
+inherit perl-module
+
+DESCRIPTION="Time zone object base class and factory"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-perl/Class-Singleton-1.30.0
+ >=virtual/perl-File-Spec-3.0.0
+ dev-perl/Module-Runtime
+ >=dev-perl/Params-ValidationCompiler-0.130.0
+ >=virtual/perl-Scalar-List-Utils-1.330.0
+ >=dev-perl/Specio-0.150.0
+ dev-perl/Try-Tiny
+ dev-perl/namespace-autoclean
+ virtual/perl-parent
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Path
+ virtual/perl-File-Temp
+ virtual/perl-Storable
+ dev-perl/Test-Fatal
+ dev-perl/Test-Requires
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"