summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/DateTime
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/DateTime')
-rw-r--r--dev-perl/DateTime/DateTime-1.030.0.ebuild30
-rw-r--r--dev-perl/DateTime/DateTime-1.120.0.ebuild30
-rw-r--r--dev-perl/DateTime/DateTime-1.180.0.ebuild39
-rw-r--r--dev-perl/DateTime/Manifest3
-rw-r--r--dev-perl/DateTime/metadata.xml15
5 files changed, 117 insertions, 0 deletions
diff --git a/dev-perl/DateTime/DateTime-1.030.0.ebuild b/dev-perl/DateTime/DateTime-1.030.0.ebuild
new file mode 100644
index 000000000000..72f2ecf44996
--- /dev/null
+++ b/dev-perl/DateTime/DateTime-1.030.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DROLSKY
+MODULE_VERSION=1.03
+inherit perl-module
+
+DESCRIPTION="A date and time object"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Params-Validate-0.760.0
+ >=dev-perl/DateTime-TimeZone-1.90.0
+ >=dev-perl/DateTime-Locale-0.440.0
+"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ dev-perl/Test-Fatal
+ )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/DateTime/DateTime-1.120.0.ebuild b/dev-perl/DateTime/DateTime-1.120.0.ebuild
new file mode 100644
index 000000000000..27a8f2d5613e
--- /dev/null
+++ b/dev-perl/DateTime/DateTime-1.120.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DROLSKY
+MODULE_VERSION=1.12
+inherit perl-module
+
+DESCRIPTION="A date and time object"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Params-Validate-0.760.0
+ >=dev-perl/DateTime-TimeZone-1.90.0
+ >=dev-perl/DateTime-Locale-0.440.0
+"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ dev-perl/Test-Fatal
+ )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/DateTime/DateTime-1.180.0.ebuild b/dev-perl/DateTime/DateTime-1.180.0.ebuild
new file mode 100644
index 000000000000..f103676d2af2
--- /dev/null
+++ b/dev-perl/DateTime/DateTime-1.180.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DROLSKY
+MODULE_VERSION=1.18
+inherit perl-module
+
+DESCRIPTION="A date and time object"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/DateTime-Locale-0.410.0
+ >=dev-perl/DateTime-TimeZone-1.740.0
+ >=dev-perl/Params-Validate-0.760.0
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Try-Tiny
+ virtual/perl-XSLoader
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.280.0
+ test? (
+ virtual/perl-ExtUtils-MakeMaker
+ virtual/perl-File-Spec
+ virtual/perl-Storable
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.880.0
+ >=dev-perl/Test-Warnings-0.5.0
+ )
+"
+
+SRC_TEST=do
diff --git a/dev-perl/DateTime/Manifest b/dev-perl/DateTime/Manifest
new file mode 100644
index 000000000000..b77e75926668
--- /dev/null
+++ b/dev-perl/DateTime/Manifest
@@ -0,0 +1,3 @@
+DIST DateTime-1.03.tar.gz 174369 SHA256 384f97c73da02492d771d6b5c3b37f6b18c2e12f4db3246b1d61ff19c6d6ad6d SHA512 6764b8bd8ccb22429d17dfc48412a0223481ae43249920347ae91514dbbe0d2f820601372b9cdae312d0ba9460c9abeae9e189afb1666b90e27b09f3daaf335f WHIRLPOOL 93903c881305ab2ca99aecb16c3100f74e0d32576565703feb6897d112056bc5b20d69f7ded92910574b514179a13adb3cd584a7910c55043eb492e9e34b7a3d
+DIST DateTime-1.12.tar.gz 206862 SHA256 e65a333806d000825724cfa23d7d33539b853b6e819d4922d2a68579416374ce SHA512 a3fde7b6d76753026b2ff3ac91761b69da3e207a51d24d693c2cf681ff9028cf6f46186e5ebf1993124d1255d080d27d7449f28eaa156b5e032e6e946dddd0a9 WHIRLPOOL 1d262bd1c788227d84b0843f182039a1007c8ac6ae7bd2cc84c9245f2fc7094aec636d4a187a25527f2e7613819d0b0bf44a3117c4aa7d190e242e966853d95a
+DIST DateTime-1.18.tar.gz 212053 SHA256 bada2c9fe3e79429f7c84592d9a9defd3a8c71f7b584389d450aa324340d913a SHA512 664cc7dacd94fb34d0b185ebfb855ce671f0c9fdbe7097617306cd3e9083fabc07acb3ca024944fe3736d52c0ed3c840c916f9af3d5c4cad0dddfcc61a25ec12 WHIRLPOOL efd79a1cd62a9e0159b3b194c0458faa1a469f0b205de618068b3536f715a7131b1aabda217a63f3b80a455aec6187468f27fd6a1ce3e04bc2f8064751d9ca1f
diff --git a/dev-perl/DateTime/metadata.xml b/dev-perl/DateTime/metadata.xml
new file mode 100644
index 000000000000..e0c32f6cf4d6
--- /dev/null
+++ b/dev-perl/DateTime/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">DateTime</remote-id>
+ <remote-id type="cpan-module">DateTime</remote-id>
+ <remote-id type="cpan-module">DateTime::Duration</remote-id>
+ <remote-id type="cpan-module">DateTime::Helpers</remote-id>
+ <remote-id type="cpan-module">DateTime::Infinite</remote-id>
+ <remote-id type="cpan-module">DateTime::Infinite::Future</remote-id>
+ <remote-id type="cpan-module">DateTime::Infinite::Past</remote-id>
+ <remote-id type="cpan-module">DateTime::LeapSecond</remote-id>
+ </upstream>
+</pkgmetadata>