summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-11-01 21:01:11 +1300
committerKent Fredric <kentnl@gentoo.org>2017-11-01 21:01:30 +1300
commite328456dc1bff7445e192aa63e47df7bd92b58d6 (patch)
tree0618acce56579876ccba73cb420cea5b97144ecd /dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.170.0.ebuild
parentdev-perl/MailTools: Bump to version 2.190.0 (diff)
downloadgentoo-e328456dc1bff7445e192aa63e47df7bd92b58d6.tar.gz
gentoo-e328456dc1bff7445e192aa63e47df7bd92b58d6.tar.bz2
gentoo-e328456dc1bff7445e192aa63e47df7bd92b58d6.zip
dev-perl/Math-BigInt-Lite: Bump to version 0.170.0
Upstream: - Improve blog() with regards to objectify() - Fix bexp() from objectifying too many args - Add from_bin, from_oct, from_hex - Correct bdiv to do floored division - Add btdiv Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.170.0.ebuild')
-rw-r--r--dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.170.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.170.0.ebuild b/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.170.0.ebuild
new file mode 100644
index 000000000000..037b684079f9
--- /dev/null
+++ b/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.170.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=PJACKLAM
+DIST_VERSION=0.17
+inherit perl-module
+
+DESCRIPTION="What BigInts are before they become big"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Math-BigInt-1.999.801
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.420.0
+ test? (
+ >=virtual/perl-Test-Simple-0.520.0
+ virtual/perl-Math-BigRat
+ )
+"
+PATCHES=("${FILESDIR}/${P}-no-dot-inc.patch")
+src_test() {
+ local bad_files=( "t/pod_cov.t" "t/pod.t" )
+ # https://rt.cpan.org/Public/Bug/Display.html?id=75667"
+ #bad_files+=( "t/bigintpm.t" )
+ perl_rm_files "${bad_files[@]}"
+ perl-module_src_test
+}