summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-22 03:12:50 +0100
committerSam James <sam@gentoo.org>2024-05-22 03:17:58 +0100
commit8437fe17240d23276621def3a33d93cb8f1bebf5 (patch)
tree1b10bcb4341fd4da52362d074ff604d9cb7e6b5e /dev-perl/Mouse
parentdev-perl/Lchown: EAPI 8, rely on eclass impls (diff)
downloadgentoo-8437fe17240d23276621def3a33d93cb8f1bebf5.tar.gz
gentoo-8437fe17240d23276621def3a33d93cb8f1bebf5.tar.bz2
gentoo-8437fe17240d23276621def3a33d93cb8f1bebf5.zip
dev-perl/Mouse: rely on eclass impls
This covers more variables/args, etc. (The eclass impl does indeed set this in configure so the comment isn't something to worry about.) Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Mouse')
-rw-r--r--dev-perl/Mouse/Mouse-2.5.10-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Mouse/Mouse-2.5.10-r1.ebuild b/dev-perl/Mouse/Mouse-2.5.10-r1.ebuild
new file mode 100644
index 000000000000..844b0cbb50ef
--- /dev/null
+++ b/dev-perl/Mouse/Mouse-2.5.10-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=SKAJI
+DIST_VERSION=v${PV}
+DIST_EXAMPLES=("example/*" "benchmarks")
+inherit perl-module
+
+DESCRIPTION="Moose minus the antlers"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=virtual/perl-Scalar-List-Utils-1.140.0
+ >=virtual/perl-XSLoader-0.20.0
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-Devel-PPPort-3.420.0
+ >=virtual/perl-ExtUtils-ParseXS-3.220.0
+ >=dev-perl/Module-Build-0.400.500
+ >=dev-perl/Module-Build-XSUtil-0.190.0
+ test? (
+ dev-perl/Test-Exception
+ dev-perl/Test-Fatal
+ dev-perl/Test-LeakTrace
+ >=virtual/perl-Test-Simple-0.880.0
+ dev-perl/Test-Output
+ dev-perl/Test-Requires
+ dev-perl/Try-Tiny
+ )
+"