summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-04-27 00:26:42 +1200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-04-29 21:35:59 +0200
commit1f334e81e1c0881fbf5677c4cb767142150546a4 (patch)
tree08b84ec36049e32eea0297a35d91456edabc3391 /dev-perl/XML-XPath
parentdev-perl/XML-RSS: Bump to version 1.590.0 (diff)
downloadgentoo-1f334e81e1c0881fbf5677c4cb767142150546a4.tar.gz
gentoo-1f334e81e1c0881fbf5677c4cb767142150546a4.tar.bz2
gentoo-1f334e81e1c0881fbf5677c4cb767142150546a4.zip
dev-perl/XML-XPath: Bump to version 1.360.0
- EAPI6 - Add USE="examples" - Cleaned up annoying tests Upstream: - /. and /.. selectors now work ( RT 30813 ) - Duplicates now removed from search results. ( RT 6362 ) - PrimaryExpr uses carp() instead of die() to give a stacktrace when parsing fails ( RT 32233 ) - Avoid regex slowdown implied by $` by removing $` usage. ( RT 23924 ) - Unabbreviated "axis" syntax of "attribute::id" now works as well as the equivalent "@id" does in setNodeText() ( RT 26143 ) - "namespace_uri()" implemented to set and read namespace URIs ( RT 68703 ) - substring matching functions in paths fixed ( RT 14957 ) - findvalue() computations that would yield infinities/NAN now match Literal NaN and Infinitities ( RT 30818 ) - creatingNode() using a namespaced path properly creates namespaced nodes ( RT 80277 ) - "<" in a query no longer acts like a "<=" query. ( RT 6363 ) - XML::XPath::PerlSAX no longer fails to compile ( RT 111278 ) - NodeSet's now implement a greater variety of comparison/casting overloads ( Github PR 2 ) - position()=last() conditions now work ( RT 32012 ) - createNode() now honors position() predicate ( RT 26144 ) - using translate() in an XPath expression no longer warns ( RT 15902 ) - translate() now removes characters as per XPath 1.0 Spec ( RT 21154 ) - xpath script now defaults to UTF-8 for IO to support wide characters ( RT 112017 ) - Warnings about /d used in translate() represssed ( RT 112584 ) - xpath script now has parameters parsed more obviously, and supports additional parameters - getAttributeNode() no longer relies on pre-perl-5.23.8 implicit return values from loops ( RT 113576 ) Keywords: - New Dependency on Path-Tiny for tests - Dropped ~alpha ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
Diffstat (limited to 'dev-perl/XML-XPath')
-rw-r--r--dev-perl/XML-XPath/Manifest1
-rw-r--r--dev-perl/XML-XPath/XML-XPath-1.360.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/XML-XPath/Manifest b/dev-perl/XML-XPath/Manifest
index a59a6746246b..4dff4b7d18e3 100644
--- a/dev-perl/XML-XPath/Manifest
+++ b/dev-perl/XML-XPath/Manifest
@@ -1 +1,2 @@
DIST XML-XPath-1.13.tar.gz 39832 SHA256 2a49c2df34007588397bdf7ae5f122df72a9499df5cbec8fbc6ad4a31a775576 SHA512 c5af746f36562803e42c5afb63b533b59ecaa263977c5ef4bf6488b7597cae334bb3b0c644acdfbb453e87a22ba9a785df3f81b95faec89d974704d6f04f6503 WHIRLPOOL 7b2cc2c3484826a426a686e7dfe516e1bcc47521002197b9d2e1172fb6a0d554ee803a52227e692b32b4a644cba535c5e73528f82bc65bb5a44db4ee5080d77a
+DIST XML-XPath-1.36.tar.gz 54662 SHA256 5391208078b4a7854ce3188d3493dc7877ee7ffc22279b19110f8bee419b1f46 SHA512 e419ac647192ca813687e211d87f59ff6cc3d0976242f4a179fb3039b4fdf1fb5b8865c62153be5795100abb8fb5efb1dc320099a55d41de7f90e94f7adad254 WHIRLPOOL 43820c4f834db5fade7e766dcba77e4cd25f562afb78eee1de887d15581ef2fe3f23fcf40cdab48bcb017942959ec8aaa7d2c4af3ce397cce1831395be9901d9
diff --git a/dev-perl/XML-XPath/XML-XPath-1.360.0.ebuild b/dev-perl/XML-XPath/XML-XPath-1.360.0.ebuild
new file mode 100644
index 000000000000..c6c709da33b0
--- /dev/null
+++ b/dev-perl/XML-XPath/XML-XPath-1.360.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=MANWAR
+DIST_VERSION=1.36
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="A XPath Perl Module"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND=">=dev-perl/XML-Parser-2.230.0"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Path-Tiny-0.76.0
+ virtual/perl-Test-Simple
+ )
+"
+src_test() {
+ perl_rm_files t/meta-json.t t/meta-yml.t
+ perl-module_src_test
+}