summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-01-07 12:38:48 -0500
committerMichael Orlitzky <mjo@gentoo.org>2017-01-07 14:23:26 -0500
commitf3a433cbfe7cfd399504f5b4cd47ceccfde91660 (patch)
tree82421d10a91ebafdc0a8dc18331d72296eecbb4a /dev-php/agavi/agavi-1.0.8.ebuild
parentdev-games/clanlib: Version bump to 4.0.0 (diff)
downloadgentoo-f3a433cbfe7cfd399504f5b4cd47ceccfde91660.tar.gz
gentoo-f3a433cbfe7cfd399504f5b4cd47ceccfde91660.tar.bz2
gentoo-f3a433cbfe7cfd399504f5b4cd47ceccfde91660.zip
dev-php/agavi: new version 1.0.8.
This new version fixes a lot of problems caused by the old PEAR build system. First, we don't need the PEAR dependencies, so they've been dropped. The docs are installed in the correct place, and the build system won't crash if you eselect the wrong version of PHP. The ebuild has been updated to EAPI=6, and has a few more USE flags to control its dependencies. Even the executable (which requires phing) is now optional. But beware: this package is mostly broken out-of-the-box. The "agavi" executable requires some code from dev-php/phing, but the phing ebuild was rewritten to use a PHAR, and no longer installs any source code. Since the old version of phing (a) would not build for me and (b) should have exactly the same problem, I don't consider that a blocker for this new version. Gentoo-Bug: 604954 Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-php/agavi/agavi-1.0.8.ebuild')
-rw-r--r--dev-php/agavi/agavi-1.0.8.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-php/agavi/agavi-1.0.8.ebuild b/dev-php/agavi/agavi-1.0.8.ebuild
new file mode 100644
index 000000000000..73be8db190ae
--- /dev/null
+++ b/dev-php/agavi/agavi-1.0.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="PHP MVC application framework"
+HOMEPAGE="http://www.agavi.org/"
+SRC_URI="http://www.agavi.org/download/${PV}.tgz -> ${P}.tgz"
+LICENSE="BSD LGPL-2.1+ icu unicode public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples +executable iconv session soap xmlrpc"
+
+RDEPEND="dev-lang/php[iconv?,session?,soap?,xml,xmlrpc?]
+ executable? ( dev-php/phing )"
+
+DOCS=(
+ API_CHANGELOG
+ CHANGELOG
+ CHANGELOG-0.9
+ CHANGELOG-0.10
+ CHANGELOG-0.11
+ CONTRIBUTING.md
+ README.md
+ RELEASE_NOTES
+ RELEASE_NOTES-0.9
+ RELEASE_NOTES-0.10
+ RELEASE_NOTES-0.11
+ UPGRADING
+)
+
+src_install() {
+ einstalldocs
+ use executable && newbin "${FILESDIR}/${PN}-executable" "${PN}"
+ use examples && dodoc -r samples
+
+ insinto "/usr/share/php/${PN}"
+ doins -r src/*
+}