summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-21 09:38:14 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-21 09:54:46 +0100
commite7f49ff752044e1bc23fb7f31c7ccbc2442d6c96 (patch)
treee766258b3f5f300f8325826241e7bda3568e1223 /dev-python/Arpeggio
parentMove dev-python/{text → textX} (diff)
downloadgentoo-e7f49ff752044e1bc23fb7f31c7ccbc2442d6c96.tar.gz
gentoo-e7f49ff752044e1bc23fb7f31c7ccbc2442d6c96.tar.bz2
gentoo-e7f49ff752044e1bc23fb7f31c7ccbc2442d6c96.zip
Move dev-python/{arpeggio → Arpeggio}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Arpeggio')
-rw-r--r--dev-python/Arpeggio/Arpeggio-1.10.2.ebuild31
-rw-r--r--dev-python/Arpeggio/Arpeggio-2.0.0.ebuild32
-rw-r--r--dev-python/Arpeggio/Manifest2
-rw-r--r--dev-python/Arpeggio/metadata.xml15
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/Arpeggio/Arpeggio-1.10.2.ebuild b/dev-python/Arpeggio/Arpeggio-1.10.2.ebuild
new file mode 100644
index 000000000000..1d8d5c5f4698
--- /dev/null
+++ b/dev-python/Arpeggio/Arpeggio-1.10.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Parser interpreter based on PEG grammars"
+HOMEPAGE="https://pypi.org/project/Arpeggio/ https://github.com/textX/Arpeggio"
+SRC_URI="https://github.com/textX/Arpeggio/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+
+DEPEND="
+ test? (
+ dev-python/memory_profiler[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e '/^setup_requires/,/^[^[:space:]]/d' \
+ -e '/^exclude/a\
+ examples.*' \
+ -i setup.cfg || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/Arpeggio/Arpeggio-2.0.0.ebuild b/dev-python/Arpeggio/Arpeggio-2.0.0.ebuild
new file mode 100644
index 000000000000..e25d2baeb0cc
--- /dev/null
+++ b/dev-python/Arpeggio/Arpeggio-2.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Parser interpreter based on PEG grammars"
+HOMEPAGE="https://pypi.org/project/Arpeggio/ https://github.com/textX/Arpeggio"
+SRC_URI="
+ https://github.com/textX/Arpeggio/archive/${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ test? (
+ dev-python/memory_profiler[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e '/^setup_requires/,/^[^[:space:]]/d' setup.cfg || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/Arpeggio/Manifest b/dev-python/Arpeggio/Manifest
new file mode 100644
index 000000000000..2089f493bee8
--- /dev/null
+++ b/dev-python/Arpeggio/Manifest
@@ -0,0 +1,2 @@
+DIST Arpeggio-1.10.2.tar.gz 766747 BLAKE2B 91e828731757b6ca1e16900edca3f45378c5bb05469e1d32571f9185dbb887f5cf6ae54afecf77f352f882d9056a0814c65aabf51424b482ae3a8cb90f11740a SHA512 c6a162f9ab854bac7e2bc9e5d5553c2dbcc068fcf61607149727cd4c8a7c87c63cab765b423c8ea76e09fa81ccc42157d724388a81e22864580ccf734998142a
+DIST Arpeggio-2.0.0.tar.gz 767813 BLAKE2B b4eab5b0a049560e8f3d775f34e9d1beffc26d3969a11a2043d203852c77385adbbef876e212b09c6af8630f2b8de6dfb088760bf9ade332af981d4e8d8267ad SHA512 b5a75eea515b7dd0ad7dc261703300bd5b3e5a70f0946845f8828dbf7c76613aef926fed9538fe0f9a71c1666edc9f8cff31afddd551bea1d7b1b9ad7a9cc405
diff --git a/dev-python/Arpeggio/metadata.xml b/dev-python/Arpeggio/metadata.xml
new file mode 100644
index 000000000000..11c23cea1edc
--- /dev/null
+++ b/dev-python/Arpeggio/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">Arpeggio</remote-id>
+ <remote-id type="github">textX/Arpeggio</remote-id>
+ </upstream>
+</pkgmetadata>