summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-14 05:14:52 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-14 05:14:52 +0100
commit79a9f9b81160783d5f202d3bc1514eff95244dfa (patch)
tree20a7d4a7f0f413902b1c488cb833b8b1958f6e24 /dev-python/a2wsgi
parentdev-python/xmlschema: Bump to 3.1.0 (diff)
downloadgentoo-79a9f9b81160783d5f202d3bc1514eff95244dfa.tar.gz
gentoo-79a9f9b81160783d5f202d3bc1514eff95244dfa.tar.bz2
gentoo-79a9f9b81160783d5f202d3bc1514eff95244dfa.zip
dev-python/a2wsgi: Bump to 1.10.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/a2wsgi')
-rw-r--r--dev-python/a2wsgi/Manifest1
-rw-r--r--dev-python/a2wsgi/a2wsgi-1.10.4.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/a2wsgi/Manifest b/dev-python/a2wsgi/Manifest
index 6034c5e268fe..89cb21cb53c6 100644
--- a/dev-python/a2wsgi/Manifest
+++ b/dev-python/a2wsgi/Manifest
@@ -1,2 +1,3 @@
DIST a2wsgi-1.10.2.tar.gz 18126 BLAKE2B 8f0163a9acd3548d5627b026cba7f573cb10d3d346b4304a2152d92f0c9c9a7c0a622ec2761c473a23ef3724d706da1c832f28f7040f7b44303a74794aff6702 SHA512 c084cdeba47c848635cd1ae8ab05d46b6d83acbad48a923f4c21141564d755ac73e52acb097251a6fb3feba9009aca03db40d9a44aa94ea89caad5218cb5e456
DIST a2wsgi-1.10.3.tar.gz 18111 BLAKE2B 2d18a17b66f3a0bf44a4b57fdc4d27361a4e0c8f540da6ae4c1be9a349fc62efcd69e4028173215e164e1823d2645a6927edfa2fedeff8fa08491f218da76149 SHA512 db1450376fec703423c06a9d9e7b4e6bb13e02b0b4f0061de1b19e63c0d27379a5a7a6d7c2d7c938044ff37ca2fd245438e023dce5ee57caef9a91be315b05ee
+DIST a2wsgi-1.10.4.tar.gz 18186 BLAKE2B 7f184c1621dd28e75c12e85b85ca4ed0b1b55d59c79797429bc188feec0ee0105e77c3613b1c2f94e1561f71fdcbabae99218e2c007ab095dd68b0502d112444 SHA512 6c050dcaca4dab0793afb267d7cbcb4faca362495c46ab9f0b52c9f2f5a1ab7dfd6fa0c543b5eaa18ddca6a789093591653f023ac9c127602138db390ae1c975
diff --git a/dev-python/a2wsgi/a2wsgi-1.10.4.ebuild b/dev-python/a2wsgi/a2wsgi-1.10.4.ebuild
new file mode 100644
index 000000000000..4dab2405e9f9
--- /dev/null
+++ b/dev-python/a2wsgi/a2wsgi-1.10.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Convert WSGI app to ASGI app or ASGI app to WSGI app"
+HOMEPAGE="
+ https://github.com/abersheeran/a2wsgi/
+ https://pypi.org/project/a2wsgi/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ <dev-python/asgiref-4[${PYTHON_USEDEP}]
+ >=dev-python/asgiref-3.2.7[${PYTHON_USEDEP}]
+ <dev-python/httpx-1[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.22.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest