summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-24 07:35:07 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-24 09:49:15 +0100
commit1523ff7ff6aa9e2404d7c507eb753571f2446682 (patch)
treea4d935317b7505bd785b24efb3aa8ceb194df00b /dev-python/agate-dbf
parentdev-python/leather: Bump to 0.4.0 (diff)
downloadgentoo-1523ff7ff6aa9e2404d7c507eb753571f2446682.tar.gz
gentoo-1523ff7ff6aa9e2404d7c507eb753571f2446682.tar.bz2
gentoo-1523ff7ff6aa9e2404d7c507eb753571f2446682.zip
dev-python/agate-dbf: Bump to 0.2.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/agate-dbf')
-rw-r--r--dev-python/agate-dbf/Manifest1
-rw-r--r--dev-python/agate-dbf/agate-dbf-0.2.3.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/agate-dbf/Manifest b/dev-python/agate-dbf/Manifest
index 55efe872b2a3..b0cd39106543 100644
--- a/dev-python/agate-dbf/Manifest
+++ b/dev-python/agate-dbf/Manifest
@@ -1 +1,2 @@
DIST agate-dbf-0.2.2.gh.tar.gz 8727 BLAKE2B 1397e87ebecff43380d17628867317e9b66584f4281609717b86c30cfa286e6d9ab32d8250c99c698c887aceae28ad4af311e0f777525283b30b65c15582895d SHA512 a92c19db922cc3f896fbe21f33afacd757a7fa3d6a26545033a898665a87765ddf4af964e4cba315cee0c70da926c965aaf68b64af86cf2aabbb9a68a65a38fe
+DIST agate-dbf-0.2.3.gh.tar.gz 7255 BLAKE2B ce6ffed843ad96667e33190bf79c2e71d8c3012700d47d7294059088b2e2dd5d9c763bdcca5fec04ed644effddcdf68437353c341fc63a87c2be2d1db87c8c2e SHA512 5d7102ab7cd58b0496759e425b76368f685454bc0a208b79091bf69f8904bc0fc8e8a15b709e3c938648713d2191d1a70553fea7b57f890aa60f7a27e93d9448
diff --git a/dev-python/agate-dbf/agate-dbf-0.2.3.ebuild b/dev-python/agate-dbf/agate-dbf-0.2.3.ebuild
new file mode 100644
index 000000000000..4aa4e26d3791
--- /dev/null
+++ b/dev-python/agate-dbf/agate-dbf-0.2.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Adds read support for DBF files to agate"
+HOMEPAGE="
+ https://github.com/wireservice/agate-dbf/
+ https://pypi.org/project/agate-dbf/
+"
+SRC_URI="
+ https://github.com/wireservice/agate-dbf/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/agate-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/dbfread-2.0.5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/furo
+distutils_enable_tests pytest