summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-16 11:08:23 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-16 12:31:31 +0100
commit740cc7d2a6ba28412fcc7fa7a5dd40d6a9f08daf (patch)
treeed2fbe9bdb0f80d7192fe0813326467b39bbac1f /dev-python/alembic
parentdev-python/mediafile: Bump to 0.11.0 (diff)
downloadgentoo-740cc7d2a6ba28412fcc7fa7a5dd40d6a9f08daf.tar.gz
gentoo-740cc7d2a6ba28412fcc7fa7a5dd40d6a9f08daf.tar.bz2
gentoo-740cc7d2a6ba28412fcc7fa7a5dd40d6a9f08daf.zip
dev-python/alembic: Bump to 1.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/alembic')
-rw-r--r--dev-python/alembic/Manifest1
-rw-r--r--dev-python/alembic/alembic-1.9.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/alembic/Manifest b/dev-python/alembic/Manifest
index e0995d34cb47..d5733e4aeeb1 100644
--- a/dev-python/alembic/Manifest
+++ b/dev-python/alembic/Manifest
@@ -1 +1,2 @@
DIST alembic-1.8.1.tar.gz 1255927 BLAKE2B dbf40f9ca12171d99ad46bec6bf1841799226887a55a815db5c7a69cbcb7d861ede774aa35e1018e1a57bec26a8ddf7ee311e0b4396ebddd5477c67a4ad11876 SHA512 51f210447172d08eb94c41a962ddecc593a665790aa6f5badb771dccc882e0d653dcf153ebb04b9824dabcaeb1ac08e3747c2e3c74d8584a24b35662778de8dd
+DIST alembic-1.9.0.tar.gz 1278832 BLAKE2B 59131c5a53d051905c13e466c58ad5c1759e0e0f557bcb78bbe80e2ca8f3f7d791a1d8be017cd9227d6baf8b7416d0c6d89ec9e9e56f7440f6d1455577ed8676 SHA512 3c040ee07ce2f40af28a63f129dee886f7d8458b762a28cf2165ac10dd2f2f732b73da2ae2c9687b66e8872b75d85d95933847eb6a1190ad55e550e6bb120a04
diff --git a/dev-python/alembic/alembic-1.9.0.ebuild b/dev-python/alembic/alembic-1.9.0.ebuild
new file mode 100644
index 000000000000..be24ef80d028
--- /dev/null
+++ b/dev-python/alembic/alembic-1.9.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Database migrations tool, written by the author of SQLAlchemy"
+HOMEPAGE="
+ https://github.com/sqlalchemy/alembic/
+ https://pypi.org/project/alembic/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/python-editor-0.3[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ dev-python/importlib_resources[${PYTHON_USEDEP}]
+ ' pypy3 python3_8)
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}