summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-27 04:28:02 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-27 04:53:45 +0200
commite8a1b81b31b3144939564c0b0f9c3b8afb1bd65e (patch)
treed6d90e6b55585cf214b5a2431498fa9d9074ea41 /dev-python/alembic
parentdev-python/jupyterlab: Bump to 4.2.3 (diff)
downloadgentoo-e8a1b81b31b3144939564c0b0f9c3b8afb1bd65e.tar.gz
gentoo-e8a1b81b31b3144939564c0b0f9c3b8afb1bd65e.tar.bz2
gentoo-e8a1b81b31b3144939564c0b0f9c3b8afb1bd65e.zip
dev-python/alembic: Bump to 1.13.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/alembic')
-rw-r--r--dev-python/alembic/Manifest1
-rw-r--r--dev-python/alembic/alembic-1.13.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/alembic/Manifest b/dev-python/alembic/Manifest
index 6134cdfa83d2..150273b584d7 100644
--- a/dev-python/alembic/Manifest
+++ b/dev-python/alembic/Manifest
@@ -1 +1,2 @@
DIST alembic-1.13.1.tar.gz 1213288 BLAKE2B 12c01f60a564c3021b3d2ae61f220822a0ca644af5097b72a826f48d04225c441f580204680674410e6e2570b5c7ee24053024863162d7d43bc423a86cddcea6 SHA512 2a5826461bec22c2efc244dd8394d34d39ed6e3511a32e8e460057ab34f9e559d28dda4ea7e34ccd30628e889a3cb37cb156596e37dba748c12a0195d78aa678
+DIST alembic-1.13.2.tar.gz 1206463 BLAKE2B edff3a244fa37556cd656e60940d94e7df75b6c67aa4199b673851b5b06e84dbf51e53f2ac9781465aa923c0019fcd33a9c3b4da90d64f583956e390ca1f5fa7 SHA512 c4952123ba00403bb030606c736dab8d5494b01662d02914fb0d10d0c1d99b27a97cc4a800cdfa32d53870031c46e351f97815e337c71f3a0a824b6403bd75cf
diff --git a/dev-python/alembic/alembic-1.13.2.ebuild b/dev-python/alembic/alembic-1.13.2.ebuild
new file mode 100644
index 000000000000..cf8af9852135
--- /dev/null
+++ b/dev-python/alembic/alembic-1.13.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Database migrations tool, written by the author of SQLAlchemy"
+HOMEPAGE="
+ https://github.com/sqlalchemy/alembic/
+ https://pypi.org/project/alembic/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/python-editor-0.3[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ sys-libs/timezone-data
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # setup.cfg contains -p no:warnings in addopts which triggers
+ # datetime.utcfromtimestamp() deprecation warning as an error in py3.12
+ epytest -o addopts=
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}