summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-31 08:13:21 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-31 08:33:42 +0200
commite2d8e99df094034318900d77e67486bd08a90374 (patch)
tree6dc90c825f5f61142270d188fa45fcbce20c459b /dev-python/ansible-compat
parentdev-python/tiny-proxy: Bump to 0.2.0 (diff)
downloadgentoo-e2d8e99df094034318900d77e67486bd08a90374.tar.gz
gentoo-e2d8e99df094034318900d77e67486bd08a90374.tar.bz2
gentoo-e2d8e99df094034318900d77e67486bd08a90374.zip
dev-python/ansible-compat: Bump to 4.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ansible-compat')
-rw-r--r--dev-python/ansible-compat/Manifest1
-rw-r--r--dev-python/ansible-compat/ansible-compat-4.1.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/ansible-compat/Manifest b/dev-python/ansible-compat/Manifest
index 8a6411da33d4..a976a42bdaf9 100644
--- a/dev-python/ansible-compat/Manifest
+++ b/dev-python/ansible-compat/Manifest
@@ -6,3 +6,4 @@ DIST ansible-compat-4.0.2.tar.gz 63771 BLAKE2B bcf66825c52de63172f7d36b696e136cc
DIST ansible-compat-4.0.4.tar.gz 65116 BLAKE2B 3f96e052cb9ba0352884fe1cfeacf9a1e5a7bbee715d08c054df49112966751067eb08f32b0598a8559e200fa9c3a619b58b854699342b6185bd9579bc75cbf2 SHA512 b13bc3d7a29b2caebfddb7a2311bfb8ad94062019238ed5a8a22fe9de1c00d25426694755cdbf289094db7fdfd88248fcf3e17e9aef9601046ef33c25d6894e6
DIST ansible-compat-4.0.5.tar.gz 65711 BLAKE2B f40e87012dba936ba8b6f204559484ff089034123da4c355f997d7cec857efc64adcd0a4ec9abe021a428f61c692b13a3e3146f78a1896689c61764286e03719 SHA512 c08bbbcbef7e49001009cbd691dc226626f1392dfc5a5be89166da0be91c8d5794a2e6a158b11787320a1dcbe24c85eedee28596b0fc27d0a3c2a499286f5efc
DIST ansible-compat-4.1.0.tar.gz 66781 BLAKE2B ce0da545e4a81798ee9376129b9f9e8c0cfd7ca641086ae55516406b73f89472a1fc44384e3728207be76cb2b8d1b724c55ff5dcf72e88a0f971ccd59aea8a8d SHA512 15b40622a00bb3b4ac3c8ed5ef05e0a65b867fbe9579352fbcbff8113d46e8da5fb5c36e0092387da4509b33244c8d27c0c08de76ff8dd78fd19e465824078c5
+DIST ansible-compat-4.1.1.tar.gz 66834 BLAKE2B 9558bd83e4662ffb9a9f45b2e5b24e36d4d1066b8fb082513ce92057a2c106b255d107a1d51a75bad3fb87e750d195e74be2918cefb599195b120ad6cd4a5ec4 SHA512 c97599b218eb32ef0c9761202cf2b616586876466626c7d249be71e4d519b417f5e85342e0cf682e2e6bc1f7b8af73863eb0afad5dfaecfce744eeed830f6956
diff --git a/dev-python/ansible-compat/ansible-compat-4.1.1.ebuild b/dev-python/ansible-compat/ansible-compat-4.1.1.ebuild
new file mode 100644
index 000000000000..bbea175e5664
--- /dev/null
+++ b/dev-python/ansible-compat/ansible-compat-4.1.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Contains functions that facilitate working with various versions of Ansible"
+HOMEPAGE="
+ https://pypi.org/project/ansible-compat/
+ https://github.com/ansible/ansible-compat/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.12[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.6.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/subprocess-tee-0.4.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-plus[${PYTHON_USEDEP}]
+ )
+"
+
+# All these tests attempt to connect to galaxy.ansible.com
+EPYTEST_DESELECT=(
+ test/test_runtime.py::test_install_collection
+ test/test_runtime.py::test_install_collection_dest
+ test/test_runtime.py::test_prepare_environment_with_collections
+ test/test_runtime.py::test_prerun_reqs_v1
+ test/test_runtime.py::test_prerun_reqs_v2
+ test/test_runtime.py::test_require_collection_no_cache_dir
+ test/test_runtime.py::test_require_collection_wrong_version
+ test/test_runtime.py::test_require_collection
+ test/test_runtime.py::test_upgrade_collection
+ test/test_runtime_example.py::test_runtime
+)
+
+distutils_enable_tests pytest