summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-09-08 19:40:01 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-09-09 23:40:59 +0200
commite253ecee00fde0c66de69142ba6edaead5379565 (patch)
tree0c97665c5439c6540942c3f557b083d65dd33ce7 /dev-python/autopep8/autopep8-1.4.ebuild
parentapp-admin/logstash-bin: drop old (diff)
downloadgentoo-e253ecee00fde0c66de69142ba6edaead5379565.tar.gz
gentoo-e253ecee00fde0c66de69142ba6edaead5379565.tar.bz2
gentoo-e253ecee00fde0c66de69142ba6edaead5379565.zip
dev-python/autopep8: version bump.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/autopep8/autopep8-1.4.ebuild')
-rw-r--r--dev-python/autopep8/autopep8-1.4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/autopep8/autopep8-1.4.ebuild b/dev-python/autopep8/autopep8-1.4.ebuild
new file mode 100644
index 000000000000..9dbeed092902
--- /dev/null
+++ b/dev-python/autopep8/autopep8-1.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.org/project/autopep8/"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.3[${PYTHON_USEDEP}]"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/pydiff-0.1.2[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # Prevent UnicodeDecodeError with LANG=C
+ sed -e "/é/d" -i MANIFEST.in || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}