summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-01 09:34:35 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-01 14:15:43 +0100
commit671b66357a902ec45cc5f379b12faacf1bc8d8a2 (patch)
tree790912c0888762da7a6ad0e4a05315e1631d9c2c /dev-python/clang-python
parentdev-ml/llvm-ocaml: Switch live to monorepo (diff)
downloadgentoo-671b66357a902ec45cc5f379b12faacf1bc8d8a2.tar.gz
gentoo-671b66357a902ec45cc5f379b12faacf1bc8d8a2.tar.bz2
gentoo-671b66357a902ec45cc5f379b12faacf1bc8d8a2.zip
dev-python/clang-python: Switch live to monorepo
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/clang-python')
-rw-r--r--dev-python/clang-python/clang-python-10.0.0.9999.ebuild8
-rw-r--r--dev-python/clang-python/clang-python-9.0.1.9999.ebuild10
2 files changed, 7 insertions, 11 deletions
diff --git a/dev-python/clang-python/clang-python-10.0.0.9999.ebuild b/dev-python/clang-python/clang-python-10.0.0.9999.ebuild
index 5a65d445f01f..24e14b038ecf 100644
--- a/dev-python/clang-python/clang-python-10.0.0.9999.ebuild
+++ b/dev-python/clang-python/clang-python-10.0.0.9999.ebuild
@@ -9,10 +9,8 @@ inherit git-r3 python-r1
DESCRIPTION="Python bindings for sys-devel/clang"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
-S=${WORKDIR}/${P}/bindings/python
-
-EGIT_REPO_URI="https://git.llvm.org/git/clang.git
- https://github.com/llvm-mirror/clang.git"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+S=${WORKDIR}/${P}/clang/bindings/python
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -32,7 +30,7 @@ DEPEND="${RDEPEND}"
src_unpack() {
git-r3_fetch
- git-r3_checkout '' '' '' bindings/python
+ git-r3_checkout '' '' '' clang/bindings/python
}
python_test() {
diff --git a/dev-python/clang-python/clang-python-9.0.1.9999.ebuild b/dev-python/clang-python/clang-python-9.0.1.9999.ebuild
index d1c47b42ebfc..45d2a38e5e59 100644
--- a/dev-python/clang-python/clang-python-9.0.1.9999.ebuild
+++ b/dev-python/clang-python/clang-python-9.0.1.9999.ebuild
@@ -9,11 +9,9 @@ inherit git-r3 python-r1
DESCRIPTION="Python bindings for sys-devel/clang"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
-S=${WORKDIR}/${P}/bindings/python
-
-EGIT_REPO_URI="https://git.llvm.org/git/clang.git
- https://github.com/llvm-mirror/clang.git"
-EGIT_BRANCH="release_90"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+EGIT_BRANCH="release/9.x"
+S=${WORKDIR}/${P}/clang/bindings/python
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -33,7 +31,7 @@ DEPEND="${RDEPEND}"
src_unpack() {
git-r3_fetch
- git-r3_checkout '' '' '' bindings/python
+ git-r3_checkout '' '' '' clang/bindings/python
}
python_test() {