summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2023-03-02 09:25:38 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-02 17:49:09 +0100
commitefd200ab8e8eae8e4eaffea6281da252de77c7da (patch)
tree96735cef54c2434c6dc6d77dff503bb0da600c4b /dev-python/configshell-fb
parentdev-python/requests-cache: Add a missing test dep on rich (diff)
downloadgentoo-efd200ab8e8eae8e4eaffea6281da252de77c7da.tar.gz
gentoo-efd200ab8e8eae8e4eaffea6281da252de77c7da.tar.bz2
gentoo-efd200ab8e8eae8e4eaffea6281da252de77c7da.zip
dev-python/configshell-fb: relax pyparsing restriction
Bug: https://bugs.gentoo.org/896764 Upstream-PR: https://github.com/open-iscsi/configshell-fb/pull/69 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/29893 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/configshell-fb')
-rw-r--r--dev-python/configshell-fb/configshell-fb-1.1.29-r2.ebuild (renamed from dev-python/configshell-fb/configshell-fb-1.1.29-r1.ebuild)8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-python/configshell-fb/configshell-fb-1.1.29-r1.ebuild b/dev-python/configshell-fb/configshell-fb-1.1.29-r2.ebuild
index 633970b1409b..c1efcb33a256 100644
--- a/dev-python/configshell-fb/configshell-fb-1.1.29-r1.ebuild
+++ b/dev-python/configshell-fb/configshell-fb-1.1.29-r2.ebuild
@@ -39,6 +39,14 @@ PATCHES=(
"${DISTDIR}/${P}-replace-getargspec-2.patch"
)
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # We can relax pyparsing version restriction,
+ # see https://github.com/open-iscsi/configshell-fb/pull/69
+ sed -i '/pyparsing/s:,<3.0::' setup.py || die
+}
+
python_test() {
"${EPYTHON}" examples/myshell || die "Test failed with ${EPYTHON}"
}