summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-24 09:01:32 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-24 09:03:56 +0100
commitf3e0be81a54623504a9be185f16a10c29f0f186b (patch)
tree4d0f57f54f2a602a5fa6aa4beedd57bc4a34a5dd /dev-python/croniter
parentdev-python/jupyter_console: Bump to 6.4.0 (diff)
downloadgentoo-f3e0be81a54623504a9be185f16a10c29f0f186b.tar.gz
gentoo-f3e0be81a54623504a9be185f16a10c29f0f186b.tar.bz2
gentoo-f3e0be81a54623504a9be185f16a10c29f0f186b.zip
dev-python/croniter: Bump to 1.0.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/croniter')
-rw-r--r--dev-python/croniter/Manifest1
-rw-r--r--dev-python/croniter/croniter-1.0.9.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/croniter/Manifest b/dev-python/croniter/Manifest
index 2ac9747b18d2..c47d7dab8e7a 100644
--- a/dev-python/croniter/Manifest
+++ b/dev-python/croniter/Manifest
@@ -1,2 +1,3 @@
DIST croniter-1.0.6.tar.gz 30489 BLAKE2B a3caf1d0606dbec7a978e5089b08bf6edb13533524f5a3f1639483547b14a83f099276f4c63e9b84031202c088a8237326f70ecaca0bf3503f4a33173ce0d358 SHA512 1ca37c7dbd6a7365db112ccd474d76babc890aad1e2c341677be13c4f4e28a98219266efc065442e2077588a36b60c01d8e2996f0a32def690cf49e2c7c584bc
DIST croniter-1.0.8.tar.gz 31019 BLAKE2B a637f7df806a85aeb236c38a9fa19ed0929fd257268cbe98bf7b281f1c52a9bfe98c91063da48b1344946f6619c5ac8f0e89051c1672fa6997c830dd97b7d9f2 SHA512 cf620baa55709c2379cc7f8f0123bd79e03b7dabaecd539633b8f52f97aa617c48e5692e0a45c08f4b30b2fab52c47cfc502c2ea550329083db2353ecdc56635
+DIST croniter-1.0.9.tar.gz 31258 BLAKE2B 01033a483f9f996ede903f9f0f648c9c2e5b270e0cce29845e264d0bbd6f792eeef69ada03ceca6b747ce4db98d79b7875f1fd9304492e40517d04f72f5a57da SHA512 3f8ceb2b759b8b80d296ac1e7994e6fa6ae7fe5b3921f9653edfbd325f88e66964366427df0b2e897abfc9d0b18b23524d8b4a8a2ab2536e37e357295edde6ab
diff --git a/dev-python/croniter/croniter-1.0.9.ebuild b/dev-python/croniter/croniter-1.0.9.ebuild
new file mode 100644
index 000000000000..705594075b4d
--- /dev/null
+++ b/dev-python/croniter/croniter-1.0.9.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module to provide iteration for datetime object"
+HOMEPAGE="https://github.com/kiorky/croniter https://pypi.org/project/croniter/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/natsort[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest