summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-23 04:28:10 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-23 04:37:18 +0100
commitf9065acbe24d427ad7d0a127add6529526dbb2f3 (patch)
tree7d826f2d921fe0c634e44db98c7ac49a9b1d0bde /dev-python/dep-logic
parentnet-misc/electrum: Bump to 4.5.3 (diff)
downloadgentoo-f9065acbe24d427ad7d0a127add6529526dbb2f3.tar.gz
gentoo-f9065acbe24d427ad7d0a127add6529526dbb2f3.tar.bz2
gentoo-f9065acbe24d427ad7d0a127add6529526dbb2f3.zip
dev-python/dep-logic: Bump to 0.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dep-logic')
-rw-r--r--dev-python/dep-logic/Manifest1
-rw-r--r--dev-python/dep-logic/dep-logic-0.1.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/dep-logic/Manifest b/dev-python/dep-logic/Manifest
index d8121fc9c663..8e4bf80d36db 100644
--- a/dev-python/dep-logic/Manifest
+++ b/dev-python/dep-logic/Manifest
@@ -1 +1,2 @@
DIST dep_logic-0.0.4.tar.gz 27197 BLAKE2B e7047c767a0c29f05975c53da0bd0ef1232abef7f34cf6430a877251a56af7fff7e3a11c28781d74d32436ef0d5ce6647356f9ebc35b2fb925333ed4d973830f SHA512 fc2d300f1a71a751cb2d983cd25251b4cfe4cf2f61397625cadaf8d528d4ca4a393714cce3fc970665c278f6711aedba936c07050d458f4111280a4031ad9edb
+DIST dep_logic-0.1.0.tar.gz 27758 BLAKE2B 89b81f5e8fcafef6f36fc95cd810a787d76cf2fa28a077beffb3396a5ef95d3993141300102e0a1360335ff3e697c58b707479c6314ac1e8657b6155f1c270b8 SHA512 eb06c6f480d306b5f45fe16ca0b452a1a6dd6318726b713e78c4be970cbd5d243e75e0850e2ff23d490c4291f8ae05442a550fda6135dc2007db1083d9f80128
diff --git a/dev-python/dep-logic/dep-logic-0.1.0.ebuild b/dev-python/dep-logic/dep-logic-0.1.0.ebuild
new file mode 100644
index 000000000000..58158724015e
--- /dev/null
+++ b/dev-python/dep-logic/dep-logic-0.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python dependency specifications supporting logical operations"
+HOMEPAGE="
+ https://github.com/pdm-project/dep-logic/
+ https://pypi.org/project/dep-logic/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ >=dev-python/packaging-22[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest