summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-08 06:36:59 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-08 07:27:14 +0100
commitef93f5d494217ebd3653dcc99e2a68c562048476 (patch)
tree0fb885ea29ce6c8212d28b3044ffee5fed02fe02 /dev-python/django-tables2
parentdev-python/pdm-pep517: Bump to 1.1.2 (diff)
downloadgentoo-ef93f5d494217ebd3653dcc99e2a68c562048476.tar.gz
gentoo-ef93f5d494217ebd3653dcc99e2a68c562048476.tar.bz2
gentoo-ef93f5d494217ebd3653dcc99e2a68c562048476.zip
dev-python/django-tables2: Bump to 2.5.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-tables2')
-rw-r--r--dev-python/django-tables2/Manifest1
-rw-r--r--dev-python/django-tables2/django-tables2-2.5.2.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/django-tables2/Manifest b/dev-python/django-tables2/Manifest
index 3896786d758c..5b5c8d167dbf 100644
--- a/dev-python/django-tables2/Manifest
+++ b/dev-python/django-tables2/Manifest
@@ -1 +1,2 @@
DIST django-tables2-2.5.1.gh.tar.gz 430778 BLAKE2B 7811880ec49a514b74252d32fbc59d800aaa34fb2bf4af5675d1c4555c7a52f9eb3ca67d8d940697146c07de1e42006c6d3880a53b31a386bd088aa6939b056f SHA512 baf955b255dcbcf09250cfdbb2dc1fb51f3f9142ad29bf4ca8888344d1bcbe9f23a59f1509cad7e847d82bb6d410a494ed9eae1d4d4ca633e7f0351e4a98839d
+DIST django-tables2-2.5.2.gh.tar.gz 430733 BLAKE2B 70aa25ca949e4244a089894a26e384d5fbdd77cc5f7b939c9fd594c70114dafd0b8134d8327d247c1272159f278c54c980a5363ad86c75af95b4ffed489468cb SHA512 0a3522cd7500e09bfbe1dd4ee102542f9e6361163195928b2d8ea301133b39aa8d417bba29b93a6166b79b744fd58889af8ae8eb49bcc2251c21dd8b9b64827e
diff --git a/dev-python/django-tables2/django-tables2-2.5.2.ebuild b/dev-python/django-tables2/django-tables2-2.5.2.ebuild
new file mode 100644
index 000000000000..823847d534f7
--- /dev/null
+++ b/dev-python/django-tables2/django-tables2-2.5.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Table/data-grid framework for Django"
+HOMEPAGE="
+ https://pypi.org/project/django-tables2/
+ https://github.com/jieter/django-tables2/
+"
+SRC_URI="
+ https://github.com/jieter/django-tables2/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/django-filter[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ # these tests require tablib
+ rm tests/test_export.py tests/test_templatetags.py || die
+ # these tests require fudge
+ rm tests/test_config.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ "${EPYTHON}" manage.py test -v 2 tests || die
+}