summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-11-27 01:57:34 +0100
committerMichał Górny <mgorny@gentoo.org>2016-11-27 11:28:33 +0100
commit8e46cb3db85f0cad547cad708b9018924bf65bcb (patch)
tree5e906232c4d902f266dee53aaaea349cc24d79c5 /dev-python/dominate/dominate-2.3.1.ebuild
parentRevert "dev-ruby/bundler: drop ia64, sparc stable keywords, bug 576632" (diff)
downloadgentoo-8e46cb3db85f0cad547cad708b9018924bf65bcb.tar.gz
gentoo-8e46cb3db85f0cad547cad708b9018924bf65bcb.tar.bz2
gentoo-8e46cb3db85f0cad547cad708b9018924bf65bcb.zip
dev-python/dominate: bump to 2.3.1
Closes: https://github.com/gentoo/gentoo/pull/2925 Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-python/dominate/dominate-2.3.1.ebuild')
-rw-r--r--dev-python/dominate/dominate-2.3.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/dominate/dominate-2.3.1.ebuild b/dev-python/dominate/dominate-2.3.1.ebuild
new file mode 100644
index 000000000000..56f49b89cde0
--- /dev/null
+++ b/dev-python/dominate/dominate-2.3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for creating and manipulating HTML documents using an elegant DOM API"
+HOMEPAGE="https://github.com/Knio/dominate"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ py.test || die "Tests failed with ${EPYTHON}"
+}