summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2021-03-20 09:49:30 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-03-20 10:25:08 +0200
commite1dc5bf6b6de1938f8f9db25d5fb5eb3c3a3db87 (patch)
treef72a93ce0ab59ee543c5910529e993c6e4ed2e6e /dev-python/exdown
parentdev-python/flask-paginate: drop 0.7.0, 0.8.0 (diff)
downloadgentoo-e1dc5bf6b6de1938f8f9db25d5fb5eb3c3a3db87.tar.gz
gentoo-e1dc5bf6b6de1938f8f9db25d5fb5eb3c3a3db87.tar.bz2
gentoo-e1dc5bf6b6de1938f8f9db25d5fb5eb3c3a3db87.zip
dev-python/exdown: drop 0.7.1, 0.8.0, 0.8.2, 0.8.5
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/exdown')
-rw-r--r--dev-python/exdown/Manifest4
-rw-r--r--dev-python/exdown/exdown-0.7.1.ebuild41
-rw-r--r--dev-python/exdown/exdown-0.8.0.ebuild25
-rw-r--r--dev-python/exdown/exdown-0.8.2.ebuild25
-rw-r--r--dev-python/exdown/exdown-0.8.5.ebuild25
5 files changed, 0 insertions, 120 deletions
diff --git a/dev-python/exdown/Manifest b/dev-python/exdown/Manifest
index 0aa461348d21..92b9f5747a03 100644
--- a/dev-python/exdown/Manifest
+++ b/dev-python/exdown/Manifest
@@ -1,5 +1 @@
-DIST exdown-0.7.1.tar.gz 4863 BLAKE2B 819e66bed1028a98293a4f30ec6dc70a8360bd018821e332719793b4c72e60f0ec09391825ee0c6eb5f4e1132f1c22d48fe0dc19fe8c42253e92a833b7821340 SHA512 4cd0abc734850b5bf8b4531f4c690400d0f5fa6a9e6efbd3e20f75f646f0373f47a04a1655ac86d95a0d6d55019a174e0361d3bdda91bdb9197e8d64ffadcab6
-DIST exdown-0.8.0.tar.gz 4864 BLAKE2B 084e359b5797484486d9554f85e07bc671da5260bcfebc5cdf20583b91f13e52f9a4332afd8b69ab3c80313d18e1f1bd0d36415a2297589c5bc65c04fde18046 SHA512 cb80d355666b57f4c35fd5776d01deb36b35547d87d152d5b5a26d5c46ecfda28af10c54a3d4ac9bd6b69f99ff3e62b07cfcade07b4cd1f51969562931aee687
-DIST exdown-0.8.2.tar.gz 5255 BLAKE2B ee33e23afc86befdb421c8ac82742977a35f5cf2931aad5cdb5fdd4096682160810bbe09661ec59c10c86f7214bf67b8dc705b9e0ebae3e818c3b112fab91831 SHA512 919b6f8d57546c308b488cc47bd8d51700ffbf758477f3d0cc9de92936a2a70828475edcea011488d653f1d53309fcb2d951ac945e76bdc9a5d015f7ac34e291
-DIST exdown-0.8.5.tar.gz 5522 BLAKE2B 30e3d6e2f12aaa5783605b8a65c391e59b563a86defcefc8f5e322f93cdd4ccc561f6514254c41109047509b77e38202365b798c2b1e7838bec9275a607d0539 SHA512 709c0f2fb6d0944357c656f3beab7f151a48000a430f863cf56c529a49ee462c1c168f9708d77fd6fd5ef3fe29b11084303da1831726bb01943e1b817ba733a4
DIST exdown-0.8.6.tar.gz 5480 BLAKE2B fe383a2092691afdb2a3fd8cfeffb78f62b23bd4dc8f8d5365102084acc8670c9f2bc3e4a0ade95a50ceffc5cc142c39dbd3e505678a238d6f39b82f6553071a SHA512 28cd68ed99d24c79a7764f7603242f2b1426f119864d39424b1326cecc5bc922ed610133099e7d03d384c485f4f67d1fefcaadee4e1f69ac8ece08136eb858e9
diff --git a/dev-python/exdown/exdown-0.7.1.ebuild b/dev-python/exdown/exdown-0.7.1.ebuild
deleted file mode 100644
index 6121e9c8720e..000000000000
--- a/dev-python/exdown/exdown-0.7.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 2019-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Extract code blocks from markdown"
-HOMEPAGE="https://github.com/nschloe/exdown"
-SRC_URI="https://github.com/nschloe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- $( python_gen_cond_dep \
- 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' python3_7 )
-"
-
-BDEPEND="
- dev-python/wheel[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # setup.py was removed in commit ddb8a613bbc8ba7d079c1b7abbca5ce2d53ef9d0
- # for some reason, DISTUTULS_USE_SETUPTOOLS="pyproject.toml" is not working
- # it complains about file not found, setup.cfg does exist
- cat > setup.py <<EOF || die
-from setuptools import setup
-
-if __name__ == "__main__":
- setup()
-EOF
-
- distutils-r1_python_prepare_all
-}
diff --git a/dev-python/exdown/exdown-0.8.0.ebuild b/dev-python/exdown/exdown-0.8.0.ebuild
deleted file mode 100644
index d8894682f3ed..000000000000
--- a/dev-python/exdown/exdown-0.8.0.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 2019-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Extract code blocks from markdown"
-HOMEPAGE="https://github.com/nschloe/exdown"
-SRC_URI="https://github.com/nschloe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/importlib_metadata[${PYTHON_USEDEP}]
- ' python3_7)
-"
-
-distutils_enable_tests pytest
diff --git a/dev-python/exdown/exdown-0.8.2.ebuild b/dev-python/exdown/exdown-0.8.2.ebuild
deleted file mode 100644
index d8894682f3ed..000000000000
--- a/dev-python/exdown/exdown-0.8.2.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 2019-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Extract code blocks from markdown"
-HOMEPAGE="https://github.com/nschloe/exdown"
-SRC_URI="https://github.com/nschloe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/importlib_metadata[${PYTHON_USEDEP}]
- ' python3_7)
-"
-
-distutils_enable_tests pytest
diff --git a/dev-python/exdown/exdown-0.8.5.ebuild b/dev-python/exdown/exdown-0.8.5.ebuild
deleted file mode 100644
index d8894682f3ed..000000000000
--- a/dev-python/exdown/exdown-0.8.5.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 2019-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Extract code blocks from markdown"
-HOMEPAGE="https://github.com/nschloe/exdown"
-SRC_URI="https://github.com/nschloe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/importlib_metadata[${PYTHON_USEDEP}]
- ' python3_7)
-"
-
-distutils_enable_tests pytest