summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-24 09:58:16 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-24 10:00:04 +0200
commit81e3a9d4511fb09cf39ee65577bc511b09eb0435 (patch)
tree3021ca22586deff7abb86999ad5ffca6d0f21ee7 /dev-python/flask-restful/flask-restful-0.3.8.ebuild
parentpackage.mask: Last rite dev-python/frozendict (diff)
downloadgentoo-81e3a9d4511fb09cf39ee65577bc511b09eb0435.tar.gz
gentoo-81e3a9d4511fb09cf39ee65577bc511b09eb0435.tar.bz2
gentoo-81e3a9d4511fb09cf39ee65577bc511b09eb0435.zip
dev-python/flask-restful: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-restful/flask-restful-0.3.8.ebuild')
-rw-r--r--dev-python/flask-restful/flask-restful-0.3.8.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/flask-restful/flask-restful-0.3.8.ebuild b/dev-python/flask-restful/flask-restful-0.3.8.ebuild
deleted file mode 100644
index eea5a35b47ce..000000000000
--- a/dev-python/flask-restful/flask-restful-0.3.8.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Simple framework for creating REST APIs"
-HOMEPAGE="
- https://flask-restful.readthedocs.io/en/latest/
- https://github.com/flask-restful/flask-restful/"
-SRC_URI="https://github.com/flask-restful/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="examples"
-
-RDEPEND="
- >=dev-python/aniso8601-0.82[${PYTHON_USEDEP}]
- >=dev-python/flask-0.8[${PYTHON_USEDEP}]
- >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/flask-restful-0.3.8-werkzeug.patch
-)
-
-distutils_enable_sphinx docs
-distutils_enable_tests nose
-
-python_install_all() {
- use examples && dodoc -r examples
- local DOCS=( AUTHORS.md CHANGES.md CONTRIBUTING.md README.md )
-
- distutils-r1_python_install_all
-}