summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-17 10:06:10 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-17 10:55:35 +0100
commitd10729c888c3989a2895f940ec559411b0454210 (patch)
tree58cc812d020b7bff0ecd534cc4870f7d8a56b5a0 /dev-python/google-api-python-client
parentdev-python/snowballstemmer: Bump to 2.2.0 (diff)
downloadgentoo-d10729c888c3989a2895f940ec559411b0454210.tar.gz
gentoo-d10729c888c3989a2895f940ec559411b0454210.tar.bz2
gentoo-d10729c888c3989a2895f940ec559411b0454210.zip
dev-python/google-api-python-client: Bump to 2.31.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.31.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 063e8c1ac858..fd3e0eda0265 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -2,3 +2,4 @@ DIST google-api-python-client-2.27.0.tar.gz 27434968 BLAKE2B 95575f70ec3a7cb71a2
DIST google-api-python-client-2.28.0.tar.gz 27582046 BLAKE2B 84803c124bdda7d93a28b9690848ab2a41bcb1327feb26cb13c17b395f6fa57d86cb4ae01095966cf5423a821c49996931dde45f95d5f23fedc05e09f875de3a SHA512 d9cbec2ad600af281df2ad6db34d146a37b8248240357d7bc8a7c651d06029dc9dba2e408aa6b7f364e30ffd2b063926e67b184d90ff66f771974ca84979d8db
DIST google-api-python-client-2.29.0.tar.gz 27697101 BLAKE2B e8c9ea3e6a0ff89dce9baef9328dd6a424b096cafe00504f28b516c753c5e9a861fe472edd3e980861c244b0642589cddf537f9a0a37ec9e089ea533b8b5d22c SHA512 c842c16496349fff2ba9522fc7144342024fcb056a79c50350c9fdd01a44f843aaaf5c7f8058595029815c0b9d4d7014ea41d28647dae6780a4dc9ee1bcddad2
DIST google-api-python-client-2.30.0.tar.gz 27735458 BLAKE2B 5ed8d7d08643bd0f67d51b4316f5eed5ff247fb68ab751cd95a35015a738601ead2b5e96b5c32293386b01297eeaf8eb80e1102f6a3364241e375c0c10461d1e SHA512 b9b403f2c8face4277858231cd72ef79d39191ca6dd1cb763ad1216a9c14315d46a08e7d70c835254c0f1405bc519bce81ac71917e03c0fa133db128edad2ff8
+DIST google-api-python-client-2.31.0.tar.gz 27822400 BLAKE2B 447d97ec10376c1a9e911023051b8e3e278db782f91e0e4c1eb72f4ba54db0498439fca42633bc9fdf16ac2982a286103d6d7a99b701b0ff30e024e131b5e175 SHA512 80359f415e2ec4c42b7e12aa333d91849a4246fd744ec627397099be261176add44bf4ada875bc353729bbbca589be59e6cad3810f609d9d23f9fb458bf2c69e
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.31.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.31.0.ebuild
new file mode 100644
index 000000000000..94711a2ec4c1
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.31.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="https://github.com/googleapis/google-api-python-client"
+SRC_URI="https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ dev-python/google-api-core[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ distutils_install_for_testing
+ epytest tests
+}