summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-01-15 16:48:52 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-01-15 16:52:19 -0800
commitbf6cf33257a020252040223cbffe8263a0251594 (patch)
tree23c9be30e5dc4a958ce1bb09e410fc7dc6acd1b9 /dev-python/grpcio-testing/grpcio-testing-1.18.0.ebuild
parentdev-python/grpcio-tools: bump to 1.18.0 (diff)
downloadgentoo-bf6cf33257a020252040223cbffe8263a0251594.tar.gz
gentoo-bf6cf33257a020252040223cbffe8263a0251594.tar.bz2
gentoo-bf6cf33257a020252040223cbffe8263a0251594.zip
dev-python/grpcio-testing: bump to 1.18.0
Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-python/grpcio-testing/grpcio-testing-1.18.0.ebuild')
-rw-r--r--dev-python/grpcio-testing/grpcio-testing-1.18.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/grpcio-testing/grpcio-testing-1.18.0.ebuild b/dev-python/grpcio-testing/grpcio-testing-1.18.0.ebuild
new file mode 100644
index 000000000000..5f8e0f83fb5b
--- /dev/null
+++ b/dev-python/grpcio-testing/grpcio-testing-1.18.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Testing utilities for gRPC Python"
+HOMEPAGE="https://grpc.io"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="~dev-python/grpcio-${PV}[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"