summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-13 23:26:35 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-14 00:13:52 +0100
commit0a042715f8202774e5b63b53f516080ff83d3e24 (patch)
tree3d08e6a4ac816a3062b3216a357949550bf252d3 /dev-python/humanize
parentdev-java/guava: Keyword 30.1.1 x86, #831439 (diff)
downloadgentoo-0a042715f8202774e5b63b53f516080ff83d3e24.tar.gz
gentoo-0a042715f8202774e5b63b53f516080ff83d3e24.tar.bz2
gentoo-0a042715f8202774e5b63b53f516080ff83d3e24.zip
dev-python/humanize: Bump to 4.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/humanize')
-rw-r--r--dev-python/humanize/Manifest1
-rw-r--r--dev-python/humanize/humanize-4.0.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/humanize/Manifest b/dev-python/humanize/Manifest
index be9a0c66f456..2ec8b83da42e 100644
--- a/dev-python/humanize/Manifest
+++ b/dev-python/humanize/Manifest
@@ -1,2 +1,3 @@
DIST humanize-3.13.1.tar.gz 72109 BLAKE2B a17033c704fb1a12a82008bf07ed1f672c6d9b8a2a1ee16e34a49b2e9ce697099951f8bad638692b183d424a20836dff42f7fb8fffd1112a8ba9c4f42365db23 SHA512 f2d510347f05f953bb6f67811a7fd062f721c76892388d43ea0f19f826e75853c6f7b6cddcd986c06414dc8a3c8b3c88bee16a61fa23baa24d951ba275114de2
DIST humanize-3.14.0.tar.gz 72030 BLAKE2B a1ba7a664c33551d9d776904b0646aad9077a53fd5a546060a9deb23e9817f1306acaddb6b133be71fdbe2a20dd3c25cef2f41448c0bc0137c657da61aad4b93 SHA512 6c3d4fba1af287023d86cc2b9bcc4b7a2fc1855271fa772b316bfab3bec2f8e0b7a91d8672e156986ccf9044dc937c3fa2e73e4537ebe919eb0869ce59c3ce73
+DIST humanize-4.0.0.tar.gz 71028 BLAKE2B ef11ae45950a4dc7f55bbd380351aa6f6aaccb7410336f3c9187755d619131741cb2932917e9316c86e33f47e0640311cce278ce23046160aa0ffb4c1bdad1bc SHA512 71c528101b62c883de6474d3c31e97f7f54099c3389f7a88a328ef24b40f7a5667db879badd6154d76ce9bb1390a45404e177c50c7c26064c63b654936ba0514
diff --git a/dev-python/humanize/humanize-4.0.0.ebuild b/dev-python/humanize/humanize-4.0.0.ebuild
new file mode 100644
index 000000000000..73e93698c1d3
--- /dev/null
+++ b/dev-python/humanize/humanize-4.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="https://github.com/jmoiron/humanize/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/freezegun[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest