summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-05 08:28:27 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-05 09:28:59 +0200
commitb0937be9df7945ce53742c56e410b77454b091a1 (patch)
tree19b358342ceb119eb6f612b9760dcb7552ef0dc4 /dev-python/jellyfish
parentapp-portage/grs: add python 3.9 (diff)
downloadgentoo-b0937be9df7945ce53742c56e410b77454b091a1.tar.gz
gentoo-b0937be9df7945ce53742c56e410b77454b091a1.tar.bz2
gentoo-b0937be9df7945ce53742c56e410b77454b091a1.zip
dev-python/jellyfish: Bump to 0.8.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jellyfish')
-rw-r--r--dev-python/jellyfish/Manifest1
-rw-r--r--dev-python/jellyfish/jellyfish-0.8.4.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/jellyfish/Manifest b/dev-python/jellyfish/Manifest
index 184cbab205ba..c45d21d0222a 100644
--- a/dev-python/jellyfish/Manifest
+++ b/dev-python/jellyfish/Manifest
@@ -1 +1,2 @@
DIST jellyfish-0.8.2.tar.gz 134200 BLAKE2B f765047414e4c1de4588d51598583c49767dde07fe2b94cdb40674bf90f4af8b5b3fa59d0ddf1e0bae3793e531426ccc941dde3fbdaa25839dd13da8b19386c4 SHA512 c4cc2b22df37497ed1ee595f03ec10b7ffe6b8441accaea77ca1b6018df07d23bbe9f2ed72d0c3e06792d6e1229b7e56f77f1758396d83120236d018ce2328da
+DIST jellyfish-0.8.4.tar.gz 137001 BLAKE2B 55ffa7b7b931bf5bd0a2bee9a378fac10212d757d0e28492aac989a836c14106d37591a63a048db16b22c11e3964ad08325fe759e9ac2841722ac491a075feea SHA512 301fed3d4ba7228738b85310272970d2c666dd120a92a61b9870918ca3778bfead2b83437aced7933459f60079efcde863425a4a86077e8a0182db7d6d6c92cf
diff --git a/dev-python/jellyfish/jellyfish-0.8.4.ebuild b/dev-python/jellyfish/jellyfish-0.8.4.ebuild
new file mode 100644
index 000000000000..837b3652da80
--- /dev/null
+++ b/dev-python/jellyfish/jellyfish-0.8.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python module for doing approximate and phonetic matching of strings"
+HOMEPAGE="https://github.com/jamesturk/jellyfish https://pypi.org/project/jellyfish/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/unicodecsv[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs --no-autodoc
+distutils_enable_tests pytest
+
+python_test() {
+ cp -r testdata "${BUILD_DIR}" || die
+ cd "${BUILD_DIR}" || die
+ epytest lib/jellyfish/test.py
+}