summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-10-28 12:10:55 -0400
committerMichael Orlitzky <mjo@gentoo.org>2023-10-28 12:11:12 -0400
commitb6cb68c716ab05607c22ea430f6fa0f007e6ca34 (patch)
tree42f3ff4ba41abe5a6c658005b89b2d4c9d3abcc2 /dev-python/lrcalc/lrcalc-2.1-r1.ebuild
parentdev-libs/libbsd: Filter -fno-semantic-interposition, bug 911726 (diff)
downloadgentoo-b6cb68c716ab05607c22ea430f6fa0f007e6ca34.tar.gz
gentoo-b6cb68c716ab05607c22ea430f6fa0f007e6ca34.tar.bz2
gentoo-b6cb68c716ab05607c22ea430f6fa0f007e6ca34.zip
dev-python/lrcalc: python-3.12 support
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-python/lrcalc/lrcalc-2.1-r1.ebuild')
-rw-r--r--dev-python/lrcalc/lrcalc-2.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/lrcalc/lrcalc-2.1-r1.ebuild b/dev-python/lrcalc/lrcalc-2.1-r1.ebuild
new file mode 100644
index 000000000000..731e35de85a3
--- /dev/null
+++ b/dev-python/lrcalc/lrcalc-2.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_EXT=1
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings for sci-mathematics/lrcalc"
+HOMEPAGE="https://bitbucket.org/asbuch/lrcalc"
+# Avoid a name clash with the sci-mathematics/lrcalc tarball
+SRC_URI="$(pypi_sdist_url) -> ${PN}_python-${PV}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+DEPEND="~sci-mathematics/lrcalc-${PV}"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Fix this typo in setup.py to avoid a QA warning
+ sed -i setup.py \
+ -e 's/long_description_type/long_description_content_type/' \
+ || die
+ default
+}