summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-30 09:11:44 +0200
committerMichał Górny <mgorny@gentoo.org>2021-03-30 09:17:12 +0200
commit70cc8855a97cb8a2193312399190a42fd72a779a (patch)
tree8f4c3a387146485545ccb6b89a6fc6c45847319e /dev-python/marshmallow
parentdev-python/importlib_metadata: Bump to 3.10.0 (diff)
downloadgentoo-70cc8855a97cb8a2193312399190a42fd72a779a.tar.gz
gentoo-70cc8855a97cb8a2193312399190a42fd72a779a.tar.bz2
gentoo-70cc8855a97cb8a2193312399190a42fd72a779a.zip
dev-python/marshmallow: Bump to 3.11.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/marshmallow')
-rw-r--r--dev-python/marshmallow/Manifest1
-rw-r--r--dev-python/marshmallow/marshmallow-3.11.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/marshmallow/Manifest b/dev-python/marshmallow/Manifest
index 7d5d0a601fdd..d84a6134ec43 100644
--- a/dev-python/marshmallow/Manifest
+++ b/dev-python/marshmallow/Manifest
@@ -1,3 +1,4 @@
DIST marshmallow-3.10.0.tar.gz 172801 BLAKE2B 1d1f5d531a9704a9b82170347e2c5dd2b3fd4488204a05f9be7705a39e5a6a42342bcce1438484c22944a6fb4470a731825314ed7ced79dbaf9cc195f049d9b2 SHA512 41520a7cfde483ca06a69e49ab04f8972932d0fbf7a6c75ef568779b55d5f2f666aead4c161e03416e9b90fba71fd73b3f14630f0d7050b8a7fe7a4bb50d5bf0
DIST marshmallow-3.11.0.tar.gz 173648 BLAKE2B 66bc79b880551c106fa88dfea3c17a171db8b7516be570882e0d686af335bb8e2667782a84a8503c2f5d5d6c4f273c93160138b97a285478f15a9aea656e6d55 SHA512 a9b2a2bb8830b1b9c773921f0a7154db3dee1840f8a6cd41a74464ed0cf91f946d00ccf8df32ed875de0201df067b0a310ddfc653e48179ca32450e48fbc06cf
+DIST marshmallow-3.11.1.tar.gz 173844 BLAKE2B edd816ccd254dc52e01a2e067ff3037fa5206ae5badb1e9b46d83d3bdcd926d324c39321e4fa2b4fdf276158d36c2d3634086f76086dececaa24213bbb765e42 SHA512 ebb6b20ffc1b199408ede0c88d1512cada14cf7220315100398137b8374940c03dda2e6449ab9135963598ab321669068a9eca0e1c4cd2f3f2454eba19db04bd
DIST marshmallow-3.5.1.tar.gz 168839 BLAKE2B 8abf8e8d45d37794c3c615f6dac8ccd0acb76357e92ddaa4c23232b7aefba63db9bd42fb7f13dd99f9ea2ec4c7608459bc36014f9344ab91894176d0f02259c9 SHA512 89b3abce9e31dad6a20cf8ceef62270c8f95cbdf80965b6d29f1728d37d51171a020463da9d0354688183ea07e3f47a0ddab8694da13fe238f11a3dc755d4d6e
diff --git a/dev-python/marshmallow/marshmallow-3.11.1.ebuild b/dev-python/marshmallow/marshmallow-3.11.1.ebuild
new file mode 100644
index 000000000000..9f52e6654547
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-3.11.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for converting to and from native Python datatypes"
+HOMEPAGE="https://github.com/marshmallow-code/marshmallow/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest