summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-05 12:08:52 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-05 12:25:06 +0100
commit18d4e41eabb22785a63356c30bae539354c4ae92 (patch)
treea2d84bed1a4ed84624a9fe70f9facd10f29fc755 /dev-python/mkdocs-monorepo-plugin
parentdev-python/stripe: Bump to 7.11.0 (diff)
downloadgentoo-18d4e41eabb22785a63356c30bae539354c4ae92.tar.gz
gentoo-18d4e41eabb22785a63356c30bae539354c4ae92.tar.bz2
gentoo-18d4e41eabb22785a63356c30bae539354c4ae92.zip
dev-python/mkdocs-monorepo-plugin: Bump to 1.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mkdocs-monorepo-plugin')
-rw-r--r--dev-python/mkdocs-monorepo-plugin/Manifest1
-rw-r--r--dev-python/mkdocs-monorepo-plugin/mkdocs-monorepo-plugin-1.1.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/mkdocs-monorepo-plugin/Manifest b/dev-python/mkdocs-monorepo-plugin/Manifest
index d1dc8d0474e3..2d9b32f75b74 100644
--- a/dev-python/mkdocs-monorepo-plugin/Manifest
+++ b/dev-python/mkdocs-monorepo-plugin/Manifest
@@ -1 +1,2 @@
DIST mkdocs-monorepo-plugin-1.0.5.tar.gz 9510 BLAKE2B 96b63fabe344f99aaefd0d3d0f547f0695fcee5b7f6d5ce027fc52ef27c1a70353c3835d0a0d02c753c48a67123bc6776a8060fa0a07640ca26f008df8f3611d SHA512 ed3c011d9a7b5a32868a4a16cbdfa1fd4ce036da2d73d59645aa5f42895f12ce7fe6d1681b53d72248b09fbdb343b2cfad3846e7005dbc8977c7ae40b8e29b30
+DIST mkdocs-monorepo-plugin-1.1.0.tar.gz 13435 BLAKE2B 5e3b0af987f0125595c32e9a68fbc5d41936081fff17a69f381789df03870cfc7efcca768de4de5663998e5437d25d24b91ab60a32106e027c5c76204aaeeaaa SHA512 8820bea9dc7e8754832c85e8b8a5e369f5ab28d388d6386912b0903739dd8bafc7dfda59bf7e4b98938ac171c7d76c9bd2e836a9c0fd05f0a61e1787e959f5da
diff --git a/dev-python/mkdocs-monorepo-plugin/mkdocs-monorepo-plugin-1.1.0.ebuild b/dev-python/mkdocs-monorepo-plugin/mkdocs-monorepo-plugin-1.1.0.ebuild
new file mode 100644
index 000000000000..cd27da0f29df
--- /dev/null
+++ b/dev-python/mkdocs-monorepo-plugin/mkdocs-monorepo-plugin-1.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Build multiple documentation folders in a single Mkdocs"
+HOMEPAGE="
+ https://backstage.github.io/mkdocs-monorepo-plugin/
+ https://pypi.org/project/mkdocs-monorepo-plugin/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=dev-python/mkdocs-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/python-slugify-4.0.1[${PYTHON_USEDEP}]
+"
+
+# Data files required by this test are not included in PyPI tarballs,
+# and upstream has not tagged any releases in their GitHub repository since 2019.
+EPYTEST_DESELECT=(
+ mkdocs_monorepo_plugin/tests/test_plugin.py::TestMonorepoPlugin::test_plugin_on_config_with_nav
+)
+
+distutils_enable_tests pytest