summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-21 06:44:29 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-21 07:14:51 +0200
commit8ffce524d01cd420c7e0136ef541416f38fe61e4 (patch)
tree560e5b2c5fba00df546b19649b64c9f319de17f6 /dev-python/nbclassic
parentdev-python/nbclassic: Remove old (diff)
downloadgentoo-8ffce524d01cd420c7e0136ef541416f38fe61e4.tar.gz
gentoo-8ffce524d01cd420c7e0136ef541416f38fe61e4.tar.bz2
gentoo-8ffce524d01cd420c7e0136ef541416f38fe61e4.zip
dev-python/nbclassic: Bump to 0.4.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nbclassic')
-rw-r--r--dev-python/nbclassic/Manifest1
-rw-r--r--dev-python/nbclassic/nbclassic-0.4.7.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/nbclassic/Manifest b/dev-python/nbclassic/Manifest
index 4aca9b8860d0..e4c1e3d4f50e 100644
--- a/dev-python/nbclassic/Manifest
+++ b/dev-python/nbclassic/Manifest
@@ -1 +1,2 @@
DIST nbclassic-0.4.6.tar.gz 19870837 BLAKE2B aba744557f6a87fd95669c0736c314714f2318abe65ed5ca0d5c4236245e27bfde52fe486e43a7369587103459598540e15738d002da859413f3f59d87f5358c SHA512 915265679194b8101ef7f11fd6a76cfa2c238d2b533f40bd3dd9f91b12488f9f5738a0f5ba06882a2898e231525a8b160506cb07f0c0837a64af6fdca1295065
+DIST nbclassic-0.4.7.tar.gz 19871431 BLAKE2B ea9b77c2676e4f70a6785b5cceaed6f233346cbc878c83e14faf23c50d4340106df0f84ee3a20bfab3f02daae5b10123ef6cc83e4d147f5d63017f02a463df1b SHA512 19ffff062fe24316e658af253210fd683b4a950b5913e978eeb98af42e76ce4c1d4dcf164c499d20814c2fe2bd9b1fcd7d09c513e71cc75615cc378f00308556
diff --git a/dev-python/nbclassic/nbclassic-0.4.7.ebuild b/dev-python/nbclassic/nbclassic-0.4.7.ebuild
new file mode 100644
index 000000000000..906c4dc832f4
--- /dev/null
+++ b/dev-python/nbclassic/nbclassic-0.4.7.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=jupyter
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="Jupyter Notebook as a Jupyter Server Extension"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/nbclassic/
+ https://pypi.org/project/nbclassic/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/jupyter_server-1.17.0[${PYTHON_USEDEP}]
+ <dev-python/notebook-7[${PYTHON_USEDEP}]
+ >=dev-python/notebook_shim-0.1.0[${PYTHON_USEDEP}]
+"
+
+# pytest-console-scripts seem unused
+BDEPEND="
+ test? (
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ )
+ doc? (
+ virtual/pandoc
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source \
+ dev-python/sphinx_rtd_theme \
+ dev-python/nbsphinx \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/myst_parser \
+ dev-python/ipython_genutils
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_tornasync.plugin
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # move /usr/etc stuff to /etc
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}