summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-11-09 21:58:54 -0500
committerEli Schwartz <eschwartz@gentoo.org>2024-11-09 22:02:55 -0500
commit26fb1617bbead3a20fbea645e7647ec9982cd38d (patch)
treed891308921b96be6dafc71b67f592790b929c68e /dev-python/pip
parentdev-php/pecl-memcached: drop 3.2.0_p20230419, 3.2.0_p20231008 (diff)
downloadgentoo-26fb1617bbead3a20fbea645e7647ec9982cd38d.tar.gz
gentoo-26fb1617bbead3a20fbea645e7647ec9982cd38d.tar.bz2
gentoo-26fb1617bbead3a20fbea645e7647ec9982cd38d.zip
dev-python/pip: fix minimum bounds for packaging dep
We were waiting on an update to packaging before bumping pip (as it imports new API from packaging 24.2), but having gotten that update we didn't actually depend on it. This causes pip to fail to build, as packaging is used at build time in order to create shell completions (and obviously for testing as well) and nothing requires packaging to update at all, let alone requires it to come first in the build queue. Closes: https://bugs.gentoo.org/943156 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'dev-python/pip')
-rw-r--r--dev-python/pip/pip-24.3.1-r2.ebuild (renamed from dev-python/pip/pip-24.3.1-r1.ebuild)2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-python/pip/pip-24.3.1-r1.ebuild b/dev-python/pip/pip-24.3.1-r2.ebuild
index fef0d38e70a2..aee9a90317e0 100644
--- a/dev-python/pip/pip-24.3.1-r1.ebuild
+++ b/dev-python/pip/pip-24.3.1-r2.ebuild
@@ -35,7 +35,7 @@ RDEPEND="
>=dev-python/distlib-0.3.9[${PYTHON_USEDEP}]
>=dev-python/distro-1.9.0[${PYTHON_USEDEP}]
>=dev-python/msgpack-1.0.8[${PYTHON_USEDEP}]
- >=dev-python/packaging-24.1[${PYTHON_USEDEP}]
+ >=dev-python/packaging-24.2[${PYTHON_USEDEP}]
>=dev-python/platformdirs-4.2.1[${PYTHON_USEDEP}]
>=dev-python/pyproject-hooks-1.0.0[${PYTHON_USEDEP}]
>=dev-python/requests-2.32.0[${PYTHON_USEDEP}]