summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyavm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyavm')
-rw-r--r--dev-python/pyavm/Manifest1
-rw-r--r--dev-python/pyavm/metadata.xml12
-rw-r--r--dev-python/pyavm/pyavm-0.9.1.ebuild36
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pyavm/Manifest b/dev-python/pyavm/Manifest
new file mode 100644
index 000000000000..792d0259ef8f
--- /dev/null
+++ b/dev-python/pyavm/Manifest
@@ -0,0 +1 @@
+DIST PyAVM-0.9.1.tar.gz 99461 SHA256 5b44dc29ee595849aed94af2db4fe670851a793713b1a3063bca2dee85aa415a SHA512 e3433a44d39cd54e20abd377c5722e7157e948cfde9176cabbe5f2a63999927ef2d9e94f1eb33da6276d6fac462fad8caa5991299483ae484aa15d9b96d9dc08 WHIRLPOOL 3b47b28685f2ffa48944bd87552a3f74282daa91444eb6a0eafb245df6292ec0f51365d76da7cde33b0d304e24ff52bd2439b1a2c150925ca6715c5f4b4af2d2
diff --git a/dev-python/pyavm/metadata.xml b/dev-python/pyavm/metadata.xml
new file mode 100644
index 000000000000..b0e9feda2056
--- /dev/null
+++ b/dev-python/pyavm/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-astronomy</herd>
+<longdescription lang="en">
+ PyAVM is a module to represent, read, and write metadata following
+ the Astronomy Visualization Metadata (AVM) standard.
+</longdescription>
+<upstream>
+ <remote-id type="pypi">PyAVM</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/dev-python/pyavm/pyavm-0.9.1.ebuild b/dev-python/pyavm/pyavm-0.9.1.ebuild
new file mode 100644
index 000000000000..ca03fad52525
--- /dev/null
+++ b/dev-python/pyavm/pyavm-0.9.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MYPN=PyAVM
+MYP=${MYPN}-${PV}
+
+DESCRIPTION="Python module for Astronomy Visualization Metadata i/o"
+HOMEPAGE="http://astrofrog.github.io/pyavm/"
+SRC_URI="mirror://pypi/${MYPN:0:1}/${MYPN}/${MYP}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/astropy-0.2[${PYTHON_USEDEP}]"
+
+DEPEND="
+ test? (
+ >=dev-python/astropy-0.2[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MYP}"
+
+python_test() {
+ py.test || die "tests for ${EPYTHON} failed"
+}