summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-15 14:57:39 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-15 15:36:22 +0200
commitc19f041fc0c78ab39d5b9d73a02c667b53baf4d1 (patch)
tree0a336d0f373ba8425b7332f3b23e126cc59034a2 /dev-python/pycares
parentnet-irc/irssi: amd64 stable wrt bug #688944 (diff)
downloadgentoo-c19f041fc0c78ab39d5b9d73a02c667b53baf4d1.tar.gz
gentoo-c19f041fc0c78ab39d5b9d73a02c667b53baf4d1.tar.bz2
gentoo-c19f041fc0c78ab39d5b9d73a02c667b53baf4d1.zip
dev-python/pycares: Bump to 2.4.0, py3.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycares')
-rw-r--r--dev-python/pycares/Manifest1
-rw-r--r--dev-python/pycares/pycares-2.4.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pycares/Manifest b/dev-python/pycares/Manifest
index b12e52f87bc2..a466b62c08a4 100644
--- a/dev-python/pycares/Manifest
+++ b/dev-python/pycares/Manifest
@@ -1,2 +1,3 @@
DIST pycares-2.1.1.tar.gz 226787 BLAKE2B 26716906e78a3fa16bcbd143f63e633ffe4664706b2230f698ea933c15d057f92a0fedc45927743690e9ef8f84191e40f4215878ff2845fd1fb4bcf91f49b765 SHA512 c3524a49f5abe4222c9371ca269918eecf30a77bd52258187766833b4663be861678ebe6f1cb2f50e824d36e75938162d5528abd5445c477f23fb85c24572403
DIST pycares-2.3.0.tar.gz 224941 BLAKE2B 9ab59f8f7294930b5ff97c7340c3f64cd039c4b291b7b33d00da85168638cdfc75552508a72afd91db28c4c1b823a018b45c346a3daf8da15d5160fd691b6c4a SHA512 dc707ab0320e03fb20e728e2e2e52e92ed3388afcf19e4553bc2a15c33a129abee39a9bc423edb7be7113d42989286ab8e8ad48699cc7433a6d8823460fd4678
+DIST pycares-2.4.0.tar.gz 214021 BLAKE2B 481d46e9a5726d953d0dcb391a549ba4177e5ac1758a0ecb25bf634b9eb6baa2fbb0544874a78ae46e30a1dd4be8a981f5ebdf1b36cb9aa2e42370074731319e SHA512 7770a2b1fd69bb800019a292e5c9fc1f737b044fb4ca5166ead197da3515f2edac55f947a68f3505c9b404745529287114667d742162c98f2ff84b2c330ef295
diff --git a/dev-python/pycares/pycares-2.4.0.ebuild b/dev-python/pycares/pycares-2.4.0.ebuild
new file mode 100644
index 000000000000..63fae6d646f7
--- /dev/null
+++ b/dev-python/pycares/pycares-2.4.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface for c-ares"
+HOMEPAGE="https://github.com/saghul/pycares/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+# Tests fail with network-sandbox, since they try to resolve google.com
+RESTRICT="test"
+
+# uses bundled/patched c-ares
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${EPYTHON}" tests/tests.py -v || die
+}