summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-22 21:45:55 +0100
committerSam James <sam@gentoo.org>2021-02-22 22:19:39 +0000
commita0f89ae825a22c2936ec98778f4a8cfc7d92f050 (patch)
treea93506dc37d0998e8294a1a446603d651436448a /dev-python/pyghmi/pyghmi-1.5.22.ebuild
parentdev-python/oslotest: Port to python 3.{8,9} (diff)
downloadgentoo-a0f89ae825a22c2936ec98778f4a8cfc7d92f050.tar.gz
gentoo-a0f89ae825a22c2936ec98778f4a8cfc7d92f050.tar.bz2
gentoo-a0f89ae825a22c2936ec98778f4a8cfc7d92f050.zip
dev-python/pyghmi: Bump to 1.5.22
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pyghmi/pyghmi-1.5.22.ebuild')
-rw-r--r--dev-python/pyghmi/pyghmi-1.5.22.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pyghmi/pyghmi-1.5.22.ebuild b/dev-python/pyghmi/pyghmi-1.5.22.ebuild
new file mode 100644
index 000000000000..4a81c80c555a
--- /dev/null
+++ b/dev-python/pyghmi/pyghmi-1.5.22.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="A pure python implementation of IPMI protocol"
+HOMEPAGE="https://github.com/openstack/pyghmi/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-python/cryptography-2.1[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/stestr-1.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ stestr run || die "Tests failed under ${EPYTHON}"
+}