summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyode')
-rw-r--r--dev-python/pyode/Manifest1
-rw-r--r--dev-python/pyode/metadata.xml8
-rw-r--r--dev-python/pyode/pyode-1.2.0_p20100322-r1.ebuild44
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pyode/Manifest b/dev-python/pyode/Manifest
new file mode 100644
index 000000000000..c737bd0d76a4
--- /dev/null
+++ b/dev-python/pyode/Manifest
@@ -0,0 +1 @@
+DIST PyODE-snapshot-2010-03-22.tar.bz2 55651 SHA256 c934fe2fc76e0b8d71d343eb5db63511ab040b226fd0148708214fc775e2998b SHA512 fd9457d9a9c42a5e9834ce45886d6b57c9ecfdc68868353d986fa219eb57246d4dc175ca5d12c876c359c5bdac5bcdaf6dfc2ee65fff52f53337b1d10458e54c WHIRLPOOL 0051aa48e88bce569c86e517e5992ab8b860f724df9a9d3b8a9d0a700223927c677b0598bc9be7430f035a59cae65d76343f30539456000467f8da63e906a9e5
diff --git a/dev-python/pyode/metadata.xml b/dev-python/pyode/metadata.xml
new file mode 100644
index 000000000000..0cbac5cb0e74
--- /dev/null
+++ b/dev-python/pyode/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="sourceforge">pyode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyode/pyode-1.2.0_p20100322-r1.ebuild b/dev-python/pyode/pyode-1.2.0_p20100322-r1.ebuild
new file mode 100644
index 000000000000..ce17f5434068
--- /dev/null
+++ b/dev-python/pyode/pyode-1.2.0_p20100322-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+inherit distutils-r1
+
+MY_P="${P/pyode/PyODE}"
+SNAPSHOT_DATE="2010-03-22" # This is a snapshot
+
+DESCRIPTION="Python bindings to the ODE physics engine"
+HOMEPAGE="http://pyode.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/PyODE-snapshot-${SNAPSHOT_DATE}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE="examples"
+
+RDEPEND=">=dev-games/ode-0.7
+ >=dev-python/pyrex-0.9.4.1[${PYTHON_USEDEP}]"
+DEPEND=${RDEPEND}
+
+S=${WORKDIR}/PyODE-snapshot-${SNAPSHOT_DATE}
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ # The build system doesnt error if it fails to build
+ # the ode library so we need our own sanity check
+ [[ -n $(find "${D}" -name ode.so) ]] || die "ode.so is missing"
+
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}