summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-22 12:03:11 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-22 12:54:35 +0100
commit778d3a3db25ea46f74de61b789adcfaff98d53f8 (patch)
treef66cfc6110a0c5f78df1d2c8fbef4076338adaea /dev-python/pypy3-exe
parentmedia-gfx/libredwg: 0.12.5: fix install of perl bindings (diff)
downloadgentoo-778d3a3db25ea46f74de61b789adcfaff98d53f8.tar.gz
gentoo-778d3a3db25ea46f74de61b789adcfaff98d53f8.tar.bz2
gentoo-778d3a3db25ea46f74de61b789adcfaff98d53f8.zip
dev-python/pypy3-exe: Fix translating with python2.7
Copy the temporary cffi._pycparser module into "pycparser". For some reason, when RPython imports it as "cffi._pycparser" rather than "pycparser", it creates humongous regexps that hit Python 2.7's group limit. Magic. Closes: https://bugs.gentoo.org/833816 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pypy3-exe')
-rw-r--r--dev-python/pypy3-exe/pypy3-exe-7.3.8.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/dev-python/pypy3-exe/pypy3-exe-7.3.8.ebuild b/dev-python/pypy3-exe/pypy3-exe-7.3.8.ebuild
index 8c18a537ee0f..259314b5d362 100644
--- a/dev-python/pypy3-exe/pypy3-exe-7.3.8.ebuild
+++ b/dev-python/pypy3-exe/pypy3-exe-7.3.8.ebuild
@@ -139,9 +139,8 @@ src_configure() {
if [[ ${EPYTHON} != pypy ]]; then
# reuse bundled pycparser to avoid external dep
- mkdir -p "${T}"/pymod/cffi || die
- : > "${T}"/pymod/cffi/__init__.py || die
- cp -r lib_pypy/cffi/_pycparser "${T}"/pymod/cffi/ || die
+ mkdir -p "${T}"/pymod || die
+ cp -r lib_pypy/cffi/_pycparser "${T}"/pymod/pycparser || die
local -x PYTHONPATH=${T}/pymod:${PYTHONPATH}
fi