summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-04 07:48:15 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-04 10:05:45 +0200
commit455fda37d609f4079eefcc209c562a434699a857 (patch)
tree0dfa1d45985261135a186d5a917300153fce2992 /dev-python/pytest-cov/pytest-cov-3.0.0.ebuild
parentdev-python/python-linux-procfs: enable py3.10 (diff)
downloadgentoo-455fda37d609f4079eefcc209c562a434699a857.tar.gz
gentoo-455fda37d609f4079eefcc209c562a434699a857.tar.bz2
gentoo-455fda37d609f4079eefcc209c562a434699a857.zip
dev-python/pytest-cov: Bump to 3.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-cov/pytest-cov-3.0.0.ebuild')
-rw-r--r--dev-python/pytest-cov/pytest-cov-3.0.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pytest-cov/pytest-cov-3.0.0.ebuild b/dev-python/pytest-cov/pytest-cov-3.0.0.ebuild
new file mode 100644
index 000000000000..e8c8e479010f
--- /dev/null
+++ b/dev-python/pytest-cov/pytest-cov-3.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin for coverage reporting"
+HOMEPAGE="https://github.com/pytest-dev/pytest-cov https://pypi.org/project/pytest-cov/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+"
+# TODO: figure out how to make tests work without pytest-cov installed
+# first
+BDEPEND="
+ test? (
+ ~dev-python/pytest-cov-${PV}[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/fields[${PYTHON_USEDEP}]
+ >=dev-python/process-tests-2.0.2[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-py3doc-enhanced-theme
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # attempts to install packages via pip (network)
+ tests/test_pytest_cov.py::test_dist_missing_data
+)