summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-06 07:14:46 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-06 07:51:35 +0100
commit82c4bf5e59b8141723d819a4f913044009fd341b (patch)
tree80c7ea5e601c12961881867b37c09710d99971a6 /dev-python/pytest-jupyter
parentdev-python/dulwich: Bump to 0.21.7 (diff)
downloadgentoo-82c4bf5e59b8141723d819a4f913044009fd341b.tar.gz
gentoo-82c4bf5e59b8141723d819a4f913044009fd341b.tar.bz2
gentoo-82c4bf5e59b8141723d819a4f913044009fd341b.zip
dev-python/pytest-jupyter: Bump to 0.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-jupyter')
-rw-r--r--dev-python/pytest-jupyter/Manifest1
-rw-r--r--dev-python/pytest-jupyter/pytest-jupyter-0.8.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytest-jupyter/Manifest b/dev-python/pytest-jupyter/Manifest
index a945176ea318..4005ef3e22df 100644
--- a/dev-python/pytest-jupyter/Manifest
+++ b/dev-python/pytest-jupyter/Manifest
@@ -1 +1,2 @@
DIST pytest_jupyter-0.7.0.tar.gz 15507 BLAKE2B b4b580668083e46830d06908f484f221e511a9dc5b32285de25e8e83268a1cb4a110ab5bc92c4652033bd658332c6aef8560313e041d39ceeec6d7339c67b24d SHA512 5bd44d1cc927281823ab92f5e1dbb4fa66e917fb9ba098c63001bb9edf60d4eb7842d4178c1dce1772e156d871def2319d511187185fbfd81ee9128c7c23ea2a
+DIST pytest_jupyter-0.8.0.tar.gz 15716 BLAKE2B 9000be141466553346737596e80c5208aa9c1bdd9a72c8b1ae9fa1b8d994dc33f6e237a2eb16e60fa9c1a9040e6711ac45b0420aa865b6c27c48455cc1a11c34 SHA512 7789d4e92a1da254c8ef161a58b63fc494e4b59ce7721d5c501fdce0975452ed53700292e1554c247f5fa58cbe1f87489403f0f5ae97c5260cc3d7c9fc1c3418
diff --git a/dev-python/pytest-jupyter/pytest-jupyter-0.8.0.ebuild b/dev-python/pytest-jupyter/pytest-jupyter-0.8.0.ebuild
new file mode 100644
index 000000000000..a63b795a126c
--- /dev/null
+++ b/dev-python/pytest-jupyter/pytest-jupyter-0.8.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pytest plugin for testing Jupyter libraries and extensions"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter-server/pytest-jupyter/
+ https://pypi.org/project/pytest-jupyter/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jupyter-client-7.4.0[${PYTHON_USEDEP}]
+ >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-1.21[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest