summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-23 17:28:06 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-23 17:42:04 +0200
commit4eb697c59015ad45e6d0a7fc36a7e0c51744f608 (patch)
treea09141d7fa52ec7d73e08c6e2b1916a6478a763a /dev-python/pytest-mock
parentdev-python/hatch-fancy-pypi-readme: Enable py3.12 (diff)
downloadgentoo-4eb697c59015ad45e6d0a7fc36a7e0c51744f608.tar.gz
gentoo-4eb697c59015ad45e6d0a7fc36a7e0c51744f608.tar.bz2
gentoo-4eb697c59015ad45e6d0a7fc36a7e0c51744f608.zip
dev-python/pytest-mock: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-mock')
-rw-r--r--dev-python/pytest-mock/pytest-mock-3.10.0.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-python/pytest-mock/pytest-mock-3.10.0.ebuild b/dev-python/pytest-mock/pytest-mock-3.10.0.ebuild
index 3d5766a44bf3..fafb81a44a96 100644
--- a/dev-python/pytest-mock/pytest-mock-3.10.0.ebuild
+++ b/dev-python/pytest-mock/pytest-mock-3.10.0.ebuild
@@ -5,7 +5,8 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_TESTED=( python3_{10..11} pypy3 )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" python3_12 )
inherit distutils-r1 pypi
@@ -25,7 +26,9 @@ RDEPEND="
BDEPEND="
dev-python/setuptools-scm[${PYTHON_USEDEP}]
test? (
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ ' "${PYTHON_TESTED[@]}")
)
"
@@ -38,6 +41,11 @@ src_prepare() {
}
python_test() {
+ if ! has "${EPYTHON/./_}" "${PYTHON_TESTED[@]}"; then
+ einfo "Skipping tests on ${EPYTHON}"
+ return
+ fi
+
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
local -x PYTEST_PLUGINS=pytest_mock,pytest_asyncio.plugin
local EPYTEST_DESELECT=()